YAFLogo

wiz
  • wiz
  • 52% (Neutral)
  • YAF Forumling Topic Starter
3 years ago
Hello,

We have been using Yaf.net for a long time but now I'm having following problem:

Today I upgraded the forum from version 2.2.xx to the latest version using this documentation:

https://github.com/YAFNET/YAFNET/wiki/Upgrade- (from-Version-1.9.5.5-or-above)

Everything went smooth and the Upgrade Wizard says the upgrade was finished successfully.

When I go to our forum it seems to work fine indeed:

https://xhammerforum.azurewebsites.net/ 

However when I try to login (or try to retrieve a forgotten password) I get following exception:

"Could not find stored procedure 'dbo.aspnet_CheckSchemaVersion'."

I'm assuming this has to do with membership/role providers but honestly I'm lost. How do I fix this ?

Our forum is hosted on Azure.

Many thanks in advance !

Sponsor
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
3 years ago
You might need to run the install of the stored procedure manually...

IF (NOT EXISTS (SELECT name
              FROM sys.objects
             WHERE (name = N'aspnet_CheckSchemaVersion')
               AND (type = 'P')))
   EXEC('CREATE PROCEDURE [dbo].aspnet_CheckSchemaVersion AS RAISERROR(''Empty aspnet_CheckSchemaVersion Procedure!!'', 16, 1) WITH SETERROR')
GO

ALTER PROCEDURE [dbo].aspnet_CheckSchemaVersion
    @Feature                   nvarchar(128),
    @CompatibleSchemaVersion   nvarchar(128)
AS
BEGIN
    IF (EXISTS( SELECT  *
                FROM    dbo.aspnet_SchemaVersions
                WHERE   Feature = LOWER( @Feature ) AND
                        CompatibleSchemaVersion = @CompatibleSchemaVersion ))
        RETURN 0

    RETURN 1
END
GO
wiz
  • wiz
  • 52% (Neutral)
  • YAF Forumling Topic Starter
3 years ago
Thanks,

I executed this and now it seems I'm getting another error when trying to log in:

Uncaught Sys.WebForms.PageRequestManagerServerErrorException: Sys.WebForms.PageRequestManagerServerErrorException: Invalid object name 'dbo.aspnet_SchemaVersions'.

It seems none of the "dbo.aspnet_xxx" tables exist. They are needed for the membership provider I assume ?

How can I generate them afterwards ? Our site & sql database are hosted on Azure.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
3 years ago

How can I generate them afterwards ?Our site & sql database are hosted on Azure.

Originally Posted by: wiz 

I assume Yaf was not initially installed on azure? At the moment the Sql membership provider scripts are only installed on a new YAF installation.

However i uploaded yaf 2.31.10

https://github.com/YAFNET/YAFNET/releases/tag/v2.3.1.10 

You need to manually run the ugprade wizard. then the needed Scripts will be installed.