YAFLogo

firebay
  • firebay
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
7 years ago
I can see your forum support IE9

But my one doesnt support IE9. seems CSS wont work. If I click compatible view, CSS works.

I didn't change any source code, just install it as instruction.

Like screen shot below, there is also "ERROR" shows up. But I dont see any detail error.

Seems css not working

 2016071405.jpg You have insufficient rights to see the content.

Sponsor
firebay
  • firebay
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
7 years ago
 2016071405.jpg You have insufficient rights to see the content.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
7 years ago
The Error Message is only shown when the css file is not correctly loaded. Is the browser console showing any errors ?
firebay
  • firebay
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
7 years ago

The Error Message is only shown when the css file is not correctly loaded. Is the browser console showing any errors ?

Originally Posted by: tha_watcha 

There is no error shown in browser console. I guess I turn the error off. how to turn it on?

firebay
  • firebay
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
7 years ago

The Error Message is only shown when the css file is not correctly loaded. Is the browser console showing any errors ?

Originally Posted by: tha_watcha 

oK, I get the Java error as screen shot below

 3.jpg You have insufficient rights to see the content. 4.jpg You have insufficient rights to see the content.

But they are in Chinese. I translate some below:

Line2, 29928,addEventListenner not support method

Line2, 29928,addEventListenner not support method

eval code (13), line 1, position1, "jQuery" is null

SCRIPT5009: “jQuery” is not defined

jquery-ui.min.js, Line 6 character 73

SCRIPT5009: “jQuery” is not defiend

jquery.ForumExtensions.min.js, 行1 字符11762

IE 8 has same error, but it shows right so far.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
7 years ago
For some reason the Rendering mode is set to IE8, in your Site which is not supported by jQuery.

Do you use the recommended web.config?

firebay
  • firebay
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
7 years ago

For some reason the Rendering mode is set to IE8, in your Site which is not supported by jQuery.

Do you use the recommended web.config?

Originally Posted by: tha_watcha 

yes, it is recommended web.config renamed from the web.recommend file. Just change the SQL link string.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
7 years ago
So for some reason your Site's rendering mode is set to IE8. The only idea i have is that is set in IIS. Because out of the box in YAF that is not enabled.

Can you try the following and change the default doctype...

Open the Default.aspx and change the line...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

with this..

<!DOCTYPE html>
firebay
  • firebay
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
7 years ago

So for some reason your Site's rendering mode is set to IE8. The only idea i have is that is set in IIS. Because out of the box in YAF that is not enabled.

Can you try the following and change the default doctype...

Open the Default.aspx and change the line...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

with this..

<!DOCTYPE html>

Originally Posted by: tha_watcha 

still same. do you have newer version? or older version for dowload and keep same database?

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
7 years ago
Or try the following add this to the section of the default.aspx

<meta http-equiv="X-UA-Compatible" content="IE=edge" /> 

or you add it to the web.config

<system.webServer>
    <httpProtocol>
      <customHeaders>
        <add name="X-UA-Compatible" value="IE=Edge" />
      </customHeaders>
    </httpProtocol>
</system.webServer>