YAFLogo

narayana
  • narayana
  • 56.8% (Neutral)
  • YAF Camper Topic Starter
9 years ago
Good day!

http://www.tran.ru  , also written on asp.net .

I try to combine these sites so that the YAF would use MasterPage from my site.

After merge two web.config in one general application seems to work.

http://149.126.169.143:8005/forum/Default_dev.aspx 

But, immediately there appeared javaScript errors associated with different versions of jQuery.

Maternal website uses version 1.7.1 jQuery, and the forum 1.10.2

In app.config commented-out settings for integration. Here they are: , , , , .

After activate these settings are integrated into one application site running, but errors in the JavaScript remain.

Please tell themes, which describes the problem has already been discussed.

Please excuse my English 🙂

Sponsor
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
9 years ago
With the settings you posted there will be stil to versions loaded, you need to disable the load of jquery via

<add key="YAF.DisableJQuery" value="true" />
narayana
  • narayana
  • 56.8% (Neutral)
  • YAF Camper Topic Starter
9 years ago

With the settings you posted there will be stil to versions loaded, you need to disable the load of jquery via

<add key="YAF.DisableJQuery" value="true" />

Originally Posted by: tha_watcha 

Yes, I understand, thank you.

Moreover, version YAF 1.9.6 (was 2.1.2) is the same version of jQuery 1.7.1 that my site.

But there is a new problem.

Namespace YAF.Properties is in the sources in C#, but disappears in YAF.dll !

Because of this, when you build the solution - error: YAF.Properties.Setting unavailable because the type name access level or namespace is not in the namespace "YAF" (are you missing an Assembly reference?)

An Assembly reference is definitely there. Moreover, I was several times rebuilt the Assembly again.

As a result, the namespace YAF.Properties is in the source, but is not in the Assembly YAF.dll .

I don't understand anything...