YAFLogo

Dimi
  • Dimi
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
13 years ago
How did you configure this forum to never ask login and password again? I noticed that my forum has expiration and I have to refresh my sessions, say, every 15 minutes. But this forum never asks me for login/password even if I return back in couple days. What's the option doing that? Is it per user machine or per server hosting the forum?

I tried to play with sessionState and it crashed the app. After I commented this key out it really helped and the app started working again. How should we set the session timeout for the forum app? I know about the key in the Web.Config file but it doesn't work in this particular case. Why?


Dimi

UserPostedImage

Sponsor
squirrel
13 years ago

How did you configure this forum to never ask login and password again? I noticed that my forum has expiration and I have to refresh my sessions, say, every 15 minutes. But this forum never asks me for login/password even if I return back in couple days. What's the option doing that? Is it per user machine or per server hosting the forum?

I tried to play with sessionState and it crashed the app. After I commented this key out it really helped and the app started working again. How should we set the session timeout for the forum app? I know about the key in the Web.Config file but it doesn't work in this particular case. Why?

Originally Posted by: Dimi 

You need to add a set of machine keys to the forum - you are experiencing app pool recycles and it is causing your cookie to be invalid. There are several posts here about this issue.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
Dimi
  • Dimi
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
13 years ago

You need to add a set of machine keys to the forum - you are experiencing app pool recycles and it is causing your cookie to be invalid. There are several posts here about this issue.

Originally Posted by: squirrel 

I found the thread, thanks!

Added on March 21, 2011.

http://www.myfoottalk.com/yaf_postst116_Forum-Timeout-Issue-is-resolved---March-21--2011.aspx 

I hope it will help somebody else to resolve a similar issue.


Dimi

UserPostedImage