YAFLogo

kislay
  • kislay
  • 54.2% (Neutral)
  • YAF Forumling Topic Starter
12 years ago
Hi All,

I have released published version of YAF v1.9.4 RC1 to my godaddy shared environment.I am getting the following error.It is working fine in my local dev environment.

Security Exception

Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: That assembly does not allow partially trusted callers.

Source Error:

Line 19: YetAnotherForum

Line 20:

Line 21:

Line 22:

Line 23:

Source File: d:\hosting\4376123\html\forum\default.aspx Line: 21

Stack Trace:

[SecurityException: That assembly does not allow partially trusted callers.]

ASP.default_aspx.__BuildControlforum() in d:\hosting\4376123\html\forum\default.aspx:21

ASP.default_aspx.__BuildControlform1() in d:\hosting\4376123\html\forum\default.aspx:20

ASP.default_aspx.__BuildControlTree(default_aspx __ctrl) in d:\hosting\4376123\html\forum\default.aspx:1

ASP.default_aspx.FrameworkInitialize() in App_Web_oltd92vy.3.cs:0

System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +56

System.Web.UI.Page.ProcessRequest() +80

System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +21

System.Web.UI.Page.ProcessRequest(HttpContext context) +49

ASP.default_aspx.ProcessRequest(HttpContext context) in App_Web_oltd92vy.3.cs:0

System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +181

System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75

I am clueless about this error.After googling i added trust level but it didn't work.

Please help me.

Thanks in advance.

Regards,

Kislay

Sponsor

kislay
  • kislay
  • 54.2% (Neutral)
  • YAF Forumling Topic Starter
12 years ago
Please help me out. Is there any solution with some config entry.

logan
  • logan
  • 100% (Exalted)
  • YAF Leader
12 years ago
Select in Publish Web site screen
test
kislay
  • kislay
  • 54.2% (Neutral)
  • YAF Forumling Topic Starter
12 years ago
Many Many Thanks It's working
bhanu2217
12 years ago
Thanks, i faced the same problem, its solved now 🙂