YAFLogo

mcdonger
  • mcdonger
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
12 years ago
After a bit more testing, it seems that you can't vote in a poll if your account was created after the poll was- is this by design or a bug?

Quote:

I'm having problems with registered members voting in polls- the options are greyed out as if they have voted or don't have permissions

I have created a test user, who I have checked is in the 'registered' group

The registered group has member access to all forums

The Member Access mask is True for 'poll' and 'vote'

...Yet the test member (and a friend of mine) can't vote in some polls. What's even more strange is that I created a new test poll, and both of us were able to post in it. I left expiry blank on the older polls which have the problem, and admin accounts still have access to vote in them. I don't know whether the problems will crop up later with the newer polls, or if I recreate the old polls, they problems will go away.

Any ideas?

Sponsor

mcdonger
  • mcdonger
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
12 years ago
I just created another test account (I wasn't 100% sure I hasn't voted already), but same problem. At the lower right of the page I see:

You can post new topics in this forum.

You can reply to topics in this forum.

You can delete your posts in this forum.

You can edit your posts in this forum.

You can create polls in this forum.

You can vote in polls in this forum.

yet the poll is still greyed out

---

EDIT:

After a bit more testing, it seems that you can't vote in a poll if your account was created after the poll was- is this by design or a bug?