YAFLogo

Gofer01
  • Gofer01
  • 100% (Exalted)
  • YAF Commander Topic Starter
14 years ago
I have YAF up and running. I can't create a second board.

Tried to create throgh Admin Pannel "Failed"
tried to create through app.config "Failed"
<!--

{app.config File)

    ** BoardID Key ** Defaults to: 1 **
  
  You can create as many boards as you want and they will function as seperate
  forums (with seperate users). (Admin->Boards to create new boards.)
  You can also specify "BoardID" in the forum control:
  
      <YAF:Forum ID="Forum1" runat="server" BoardID="2" />
-->
    <add key="YAF.BoardID" value="1" />
    <add key="YAF.BoardID" value="2" />

tried to create through Defaul2.aspx using this code as the only code "Failed"

<YAF:Forum ID="Forum1" runat="server" BoardID="2" />

I tried to used the combonation settings of app.config and Default2.aspx at the same time. "Failed"

What am I'm doing wrong?

Board is running on IIS 5.1 with Netframework 3.5
Sponsor

logan
  • logan
  • 100% (Exalted)
  • YAF Leader
14 years ago
Try this setup. I've set it up this way and seems to work fine.

http://forum.yetanotherforum.net/yaf_postst8688_Multiple-Boards-Multiboards-Solution.aspx 

As for creating the new board from the admin panel. If you are getting a error

like a FK constraint you need to delete or rename the TEST FORUM to another name.

test
Gofer01
  • Gofer01
  • 100% (Exalted)
  • YAF Commander Topic Starter
14 years ago
Thank you for your assistance 🙂
Gofer01
  • Gofer01
  • 100% (Exalted)
  • YAF Commander Topic Starter
14 years ago
logan wrote:

Try this setup. I've set it up this way and seems to work fine.

http://forum.yetanotherforum.net/yaf_postst8688_Multiple-Boards-Multiboards-Solution.aspx 

As for creating the new board from the admin panel. If you are getting a error

like a FK constraint you need to delete or rename the TEST FORUM to another name.


It didn't worked. Got same error reading

UserPostedImage UserPostedImage

Follow instructions to the letter

The sub dirctory was named 1 the web.config looked like this
<?xml version="1.0"?>
<configuration>
	<appSettings configSource="app.config" />
</configuration>

The app.config looked like this
<appSettings>
  <!--
  ******************************************************************
	** ConfigPassword Key ** Defaults to: Empty (not installed) **
  
  Password to run configuration (/install/default.aspx) for the forum.
  If you cannot set write permissions on this file (app.config)
  you can manually enter a plain text password here that will
	be required when you attempt to run the configuration. Install/config
	password is required for security reasons.
   -->
	<add key="YAF.ConfigPassword" value="****************" />
	
  <!--
  ******************************************************************
	** BoardID Key ** Defaults to: 1 **
  
  You can create as many boards as you want and they will function as seperate
  forums (with seperate users). (Admin->Boards to create new boards.)
  You can also specify "BoardID" in the forum control:
  
  	<YAF:Forum ID="Forum1" runat="server" BoardID="2" />
  	
   -->
  <add key="YAF.BoardID" value="2" />
  
  <!--
  ******************************************************************
	** EnableURLRewriting Key ** Defaults to: false **
  
  For advanced users who need SEO-quality URLs on their forum. If
  you don't know what SEO is, you probably don't need to enable.
  -->  
  <add key="YAF.EnableURLRewriting" value="true" />
  
  <!--
  ******************************************************************
	** databaseObjectQualifier Key ** Defaults to: yaf_ **
  
  For advanced users who want to change the prefix for Yaf DB
  structure.
  -->
  <add key="YAF.DatabaseObjectQualifier" value="yaf_" />
  
  <!--
  ******************************************************************
	** databaseObjectQualifier Key ** Defaults to: yaf_ **
  
  For advanced users who want to the change the default permissions
  for the YAF DB structure.
  -->  
  <add key="YAF.DatabaseOwner" value="dbo" />
  
  <!--
  ******************************************************************
	** providerExceptionXML Key ** Defaults to: ProviderExceptions.xml **
  
  The file that the providers pull exception messages from.
  -->  
  <add key="YAF.ProviderExceptionXML" value="ProviderExceptions.xml" />
  
  <!--
	******************************************************************
	** UploadDir Key ** Defaults to: "~/upload/" **

	Provide a relative path to the directory where
	uploads will go if different from the default. Make sure
	there is write permissions to this directory.
	-->
  <add key="YAF.UploadDir" value="~/upload/" />
	  
  <!--
	******************************************************************
	** Membership Provider Key Type ** Defaults to: "System.Guid" **

	The type that the membership provider expects the ProviderKey
	to be. Most providers use expect System.Guid.
	
	Valid values include:
	
	System.Guid (default)
	System.String (max 64 character length)
	System.Int32
	System.Int64
		
	-->
  <add key="YAF.ProviderKeyType" value="System.Guid" /> 

  <!--
	****************************************************************** 
	** Optional Root Key ** Defaults to: "~/" **

	If YAF forum files are not located in the Application Root (~/)
	of your web site you need to specify the additional url
	in this root key. Example: Application Root is "www.mysite.com/"
	You want your forum at "www.mysite.com/forum". You need to specify
	"/forum" in your root key below.
	
	PLEASE NOTE: 

	YAF .dll files (from the \bin directory in the zip) AND ALL files 
	in the \App_Code directory MUST be located in the Application Root.
	
  <add key="YAF.Root" value="/forum"/>  
  -->
  
  <!--
	****************************************************************** 
	** Optional Base URL ** Defaults to: "~/" **

	If YAF forum URL is different than the Application Root,
	you will need to specify the BaseURL here of the forum.
	
	e.g. ~/forumff
	
	If you use the BaseUrlOverrideDomain key, you can also include
	the complete URL for the forum even if the domain is different
	than the domain the web server registers. (Domain masking)
	
	e.g. https://www.myforumdomain.com/forum
	e.g. http://www.myforumdomain.net
	--><!--
  <add key="YAF.BaseUrl" value="~/" />-->
	  
  <!--
	****************************************************************** 
	** Optional Base URL Override Domain ** Defaults to: "false" **

	Use this key with the BaseURL key above to specify a domain 
	mask for your YAF forum.	
	-->
  <add key="YAF.BaseUrlOverrideDomain" value="false" />

  <!--
  ******************************************************************
  ** Optional ShowToolBar ** Defaults to: "true" **

  You can hide the toolbar with the optional key below.  You may want
  to do this if you've incorporated YAF into your existing site and
  have your own menu controls for accessing the forum.
  
  <add key="YAF.ShowToolBar" value="false" />
  -->

  <!-- RadEditor configuration settings-->
  <add key="YAF.RadEditorSkin" value="Black"/>
  <add key="YAF.UseRadEditorToolsFile" value="true"/>
  <add key="YAF.RadEditorToolsFile" value="editors/radEditor/toolsFile.xml" />
  <!-- RadEditor configuration settings-->
</appSettings>

the default.aspx looked like this

<%@ Page Language="C#" AutoEventWireup="true" ValidateRequest="false" %>
<script runat="server">
    public void Page_Error( object sender, System.EventArgs e )
    {
        Exception x = Server.GetLastError();
        YAF.Classes.Data.DB.eventlog_create( YafContext.Current.PageUserID, this, x );
        YAF.Classes.Utils.CreateMail.CreateLogEmail( x );
    }		
</script>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="YafHead" runat="server">
    <meta name="Description" content="A bulletin board system written in ASP.NET" />
    <meta name="Keywords" content="Yet Another Forum.net, Forum, ASP.NET, BB, Bulletin Board, opensource" />
    <title>This title is overwritten</title>
</head>
<body>
    <img src="~/images/YAFLogo.jpg" runat="server" alt="YetAnotherForum" id="imgBanner" /><br/>
    <form id="form1" runat="server" enctype="multipart/form-data">
        <YAF:Forum ID="Forum1" runat="server" BoardID="2" />
    </form>
</body>
</html>

the bin and appl_code directories were removed. the dirctory was a phyical directory not a vitural directory. I keep the mail.config and DB.config in sub dirctory. It showed the continue error for about 5 seconds then revert back to the primary Forum. I ran the forums install program to configure the DB. I ran build web site from VS 2008 Pro. On the build I recieved no errors. The only thing thats not the default setting is the SEO key I change it from false to true.
Mek
  • Mek
  • 100% (Exalted)
  • YAF Developer
14 years ago
You can't put two boards:

<add key="YAF.BoardID" value="1" />
    <add key="YAF.BoardID" value="2" />


You can't have both in app.configs; its one or the other. You would need to setup another install of YAF with the BoardID set to 2 to make use of a second board but you can use the same DB.

Edit: Just noticed you'd followed the advice.

YAF will take the BoardID from the app.config or the default.aspx forum control setting i.e. setting. So try using one and not both.






UserPostedImage

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
Gofer01
  • Gofer01
  • 100% (Exalted)
  • YAF Commander Topic Starter
14 years ago
Mek wrote:

You can't put two boards:


<add key="YAF.BoardID" value="1" />
    <add key="YAF.BoardID" value="2" />


You can't have both in app.configs; its one or the other. You would need to setup another install of YAF with the BoardID set to 2 to make use of a second board but you can use the same DB.

Edit: Just noticed you'd followed the advice.

YAF will take the BoardID from the app.config or the default.aspx forum control setting i.e. setting. So try using one and not both.






Ah Found something that this forum doesn't have but needs to add. I tried to print this hole topic out on my printer . This Forum doesn't have printer friendly view capibilities.

Thanks for the assistance.

Will try this. Right now I don't understand the advise. I understand that I have to make a choice on something I doubled up on. I thiink that I can figuree out the solution after I read the help file several times
Gofer01
  • Gofer01
  • 100% (Exalted)
  • YAF Commander Topic Starter
14 years ago
Mek wrote:

You can't put two boards:


<add key="YAF.BoardID" value="1" />
    <add key="YAF.BoardID" value="2" />


You can't have both in app.configs; its one or the other. You would need to setup another install of YAF with the BoardID set to 2 to make use of a second board but you can use the same DB.

Edit: Just noticed you'd followed the advice.

YAF will take the BoardID from the app.config or the default.aspx forum control setting i.e. setting. So try using one and not both.






Can you show me where I double up with the same codes? Is it here


app.config

UserPostedImage

Default.aspx

UserPostedImage

Thanks
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button