YAFLogo

celtica
  • celtica
  • 50.6% (Neutral)
  • YAF Forumling Topic Starter
13 years ago
Hi,

I am trying to get YAF 1.9.3 up and running on my web server and am getting the following error:

Quote:


Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:


Line 35:
Line 36:
Line 37:
Line 38:
Line 39:



Source File: D:\Data\WWW\xxxxx\forum2\web.config Line: 37



Show Additional Configuration Errors:


It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (D:\Data\WWW\xxxx\forum2\web.config line 105)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (D:\Data\WWW\xxxx\forum2\web.config line 111)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (D:\Data\WWW\xxxx\forum2\web.config line 117)





Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053



I used the recommended web.config file and can post it here if nessesary.

I am a total noob when it comes to .Net apps and YAF, any help would be appreciated.

Thanks.
Sponsor

herman_herman
13 years ago
Your installation folder is not set to be a virtual directory.You can either make it a virtual directory via IIS or your host panel or consult install.txt for installation in subdirectory.
paiman
  • paiman
  • 55.4% (Neutral)
  • YAF Camper
13 years ago
I'm having the same problem.
Is everything different in 1.9.3??
I added this key to app.config (well, copied it from the comments)

but I'm still getting the exception.
Is this how I am supposed to do it?
ممنون می شم جواب بدید.
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button