guest
2004-05-10T13:21:37Z
When I try to upload a file I always get the message 'access to the
path (path) is denied'. I'm sure I have set uploaddir in web.config to
an existing directory and that I have write access to it, because I can
upload files to that directory using my own home-made asp applications
which uses aspSmartUpload. Or do I have to ask my ISP for specific
write access for asp.net?

Sponsor
pro-logic
2004-05-10T23:47:09Z

The path has to be relative to the bin directory of the forum not to the root of the site... if you can give me an idea of how the foder layould looks and where the bin directory is i can help... alernativley you can click "Store in Table"


guest
2004-05-12T09:06:28Z
Ok, I first tried it relative to the root which is /tel18/forum, so I
was using /tel18/forum/upload/ (where forum/ is set as an application
in IIS). When I tried to upload a file a got the error message that the
access to D:\WWWroot\projects\tel18\forum\upload\44.testfile.sxw was
denied. Then I tried /tel18/documents/ as the directory for uploads,
because I know that I have write access to the 'documents' directory (I
can succesfully upload files to it with some homewritten asp page which
uses aspSmartUpload), but again I got the access denied (this time with
path D:\WWWroot\projects\tel18\documents\44.testfile.sxw)

When I tried /tel18/documents/upload, while the directory 'upload'
didn't exist, I get a message that the folder upload doesn't exist.
After I had created the folder 'upload' it gave me the error message
that the access was denied, so IMHO yaf, looks in the right directory
(although i had set the path relative to the root of the website)

To try your suggestion, i set the path to ../documents/ (both the
folders 'documents' and 'forum' are child-directories of 'tel18', and
'forum' is set up as an application, so the bin directory is in forum/.
But also with these settings I get the error 'access denied' with exact
the same path as when I use a path relative to the root of the website.



So am I doing something wrong, or is there some setting on the server of my ISP that needs to be changed?



Thx for your time 🙂
pro-logic
2004-05-12T11:43:38Z

Its possible the ASP.NET does not have "write access".


This could be caused because the ASP.NET "user" that the ISP uses has no write access or its disabled on your folders.


guest
2004-05-12T13:17:01Z
pro-logic wrote:

Its possible the ASP.NET does not have "write access".
This could be caused because the ASP.NET "user" that the ISP uses has
no write access or its disabled on your folders.



Ah OK, then I'll mail my ISP about this :-)

Thx for your time and support! Oh and ofcourse the nice app!

guest
2004-05-12T22:43:03Z
Hmm... I mailed my ISP and he confirmed me that write access for asp
and asp.net on his server are the same, so I should be able to write in
the directory /tel18/documents/



[update] To be sure, I tried uploading it with a locally installed
version of the board on my localhost, and this works, so it is not that
i'm doing something wrong with the settings IMHO... [/update]
jwendl
2004-05-14T21:29:25Z

TeRanEX wrote:

Hmm... I mailed my ISP and he confirmed me that write access for asp and asp.net on his server are the same, so I should be able to write in the directory /tel18/documents/

[update] To be sure, I tried uploading it with a locally installed version of the board on my localhost, and this works, so it is not that i'm doing something wrong with the settings IMHO... [/update]


Your ISP needs to make sure that the asp.net user and the NETWORK SERVICE user has read / write permissions inside ACL on his server for that directory. Then he also needs to make sure that IIS is allowing read / write to that directory. If it works local host it is because you are logged in as a USER and thus windows allows USERs to write to that directory on localhost.


When connecting via IIS it is using a username called NETWORK SERVICE which is really what needs to be granted write access to that folder.


Sorry there is no work around for this :?


He felt that his whole life was some kind of dream and he sometimes wondered whose it was and whether they were enjoying it.
-Douglas Adams
guest
2004-05-16T10:26:14Z
jwendl wrote:

TeRanEX wrote:

Hmm... I mailed my ISP and he confirmed me
that write access for asp and asp.net on his server are the same, so I
should be able to write in the directory /tel18/documents/


[update] To be sure, I tried uploading it with a locally
installed version of the board on my localhost, and this works, so it
is not that i'm doing something wrong with the settings IMHO...
[/update]


Your ISP needs to make sure that the asp.net user and the NETWORK
SERVICE user has read / write permissions inside ACL on his server for
that directory. Then he also needs to make sure that IIS is allowing
read / write to that directory. If it works local host it is because
you are logged in as a USER and thus windows allows USERs to write to
that directory on localhost.


When connecting via IIS it is using a username called NETWORK
SERVICE which is really what needs to be granted write access to that
folder.


Sorry there is no work around for this :?



Thx for the explanation 🙂 problem is that we almost get the
webspace for free (we're a non profit organization for youth) and that
he already is a bit angry because i mailed him alreadt about 10 times
to get the forum working (something was wrong with the application
setting for the directory our website is in... I'll try mailig him in a
few weeks 😉 THX!!

jit
  •  jit
  • 53% (Neutral)
  • YAF Camper
2009-10-25T07:29:48Z
Hi,

I faced with the same issue before and I managed to resolve it.

Following permission from ASP.NET/IIS for ref.

Good look!
jit
jit attached the following image(s):

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved