YAFLogo

salibsatan
  • salibsatan
  • 50.6% (Neutral)
  • YAF Forumling Topic Starter
2009-03-10T09:52:10Z
hi my friends.i see 3 topics with same name but i cant find my answer.please someone help me & answer completly to my questions...

1*how can i upgrade YAf 1.9.1.8 to 1.9.3?

2*i want my user names&passwords(My Users),Topics,Posts and ...etc( My database) will work after upgrade.is that possible?or they can`t be available?if i should do something before upgrade,please tell me...

thanks

Sponsor
Mek
  • Mek
  • 100% (Exalted)
  • YAF Developer
2009-03-10T10:20:43Z
Download 1.93 and look at the instructions in install.txt (unless someone changed the name, but it'll be quite obvious). You need to make sure you choose the right web.config the webconfigs folder in order to get it to work. (Again instructions in the text file).

Then its the same as all YAF updates run install/default.aspx and follow the instructions.

BUT AS ALWAYS BACKUP BEFORE YOU ATTEMPT THIS AND 1.93 IS CURRENTLY RELEASE CANDIDATE NOT FINAL!

Excuse me for shouting the obvious.


UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )

Schmakt
  • Schmakt
  • 55.4% (Neutral)
  • YAF Forumling
2009-03-16T09:53:24Z
I have been relatively successful in upgrading from 1.9.1.8 to 1.9.3 by following most of the instructions in the install.txt file. This is for a site which has the forum embedded in a master page and was using the yaf.DB login scripts for user management.

What I did...

(My old forum directory was ~/forum/)

- Remove the /forum folder from the project

- unzip the contents of the .zip file to a new /forum folder in the Application root

- Rename the current web.config file

- Copy the dev.upgrade web.config file to the Application Root; rename to web.config

- Manually merged the information from my old web.config file to the new web.config file

- Since I had several connection strings defined, I moved the connection strings from web.config to db.config

- Modify db.config to point to the proper YAF database

- Modify app.config by adding the "root" key with the value "/forum/"

- Copy contents of forum/Bin to ~/Bin

- Copy contents of forum/App_Code to ~/App_Code **This step is missing from install.txt**

At this point, when I ran the application, I had errors on this line in my web.config file:

I haven't noticed a difference b/t the 2 solutions, but I was able to get around the error by doing either of the following:

- Move URLRewriter.config to the Application root

- Modify the line above to

This also had to be done with app.config and db.confg

I can now run the Application and access both ~\default.aspx and ~\forum\default.aspx

with a couple of major problems...

- AjaxControlToolkit seems to have fallen apart. My ACT controls that were in my existing application are no longer displayed...

- While the forum loads (and correctly displays my forums, posts, and users from v 1.9.1.8) any link I click directs me back to ~\default.aspx instead of ~\forum\default.aspx.

The ACT error seems to be a problem with my computer and refreshing. I've been testing in Chrome, but when I flip to FF, everything works again. I think it's a cache error; I'm going to reboot and try to find out.

In trying to fix the 2nd problem, I am now getting errors anytime I load any forum page saying that "The virtual path '/forum/pages/forum.ascx' maps to another application, which is not allowed."

Will work on that after reboot... but, if that (and the link problem) are fixed, it looks like this is working.

Next step is to update the Login / Authentication stuff

EDIT:

- Reboot did not solve the ACT error... I deleted the .dll from my project and then added it back. I also had to re-add the Reference. This made VS stop giving me the error, but there is still strange behavior with ACT controls in Chrome. All controls tested thus far still work in FF...

- I copied the app.Config and URLRewriter.config files from the downloaded .zip file back into my project. This solved the "The virtual path..." error. I'm not sure what I did wrong.

- But... the links from within the forum are still all pointing back to the application root. I've tried modifying both the root and baseurl nodes of app.Config but neither one seem to have any effect... no matter what I type in the fields. If I can't figure this out by 5, I'll probably post as its own question on the forum.

Hope this helps someone out there...

crap... EDIT #2:

- I should mention that all of the ACT controls were working fine in Chrome prior to my upgrade of YAF

EDIT #3:

- I am baffled but happy. I reran the YAF install file (this time including full text search)... when I clicked finish, it spat me back to the application root. But now, when I am accessing the forum, links correctly point to the relative path within the forum directory. Since I had copied the app.config file back into my application from the YAF .zip file, I had to reset the password. This, perhaps, helped kick the linking back into shape. *no idea*

Schmakt
  • Schmakt
  • 55.4% (Neutral)
  • YAF Forumling
2009-03-18T07:47:51Z
One more update...

I don't remember where I saw this, but someone had mentioned deleting all of the database tables and starting over with the install.

Since I didn't have any posts or users, I was able to do this fairly easily.

After I removed all the tables and reran the install script, ACT began functioning properly across all browsers including Chrome. I have absolutely no idea how this happened, but it worked, and now I'm rolling.

The code from this post:

http://forum.yetanotherforum.net/yaf_postsm32621_MembershipProvider-integration-with-ASPNET-App-and-YAF--Need-assistance-getting-past-the-issue.aspx#post32621 

for manually handling logins was spot on and saved me a lot of time.

GeorgePlummer
2009-04-07T16:49:13Z
Did you ever solve the problem where all the links point to the site root? I am getting the same behaviour.

Thanks.