vash
  •  vash
  • 100% (Exalted)
  • YAF Commander
2008-11-11T03:49:27Z
It still has the same problem 😞
midwestSS
2008-11-11T16:34:58Z
oh well,
I give up. I tried installing VS 2005 SP1, and it keeps telling me I cant open the project, the application is not installed.. yada yada yada.. blah blah blah...
I installed VS 2008, i can open the project, but when i try to build it...

Error 1 Unknown server tag 'YAF:LocalizedLabel'. C:\Documents and Settings\me\Desktop\yaf\YAF-v1.9.3-RC2-SRC\YetAnotherForum.NET\controls\EditUsersAvatar.ascx 6

i get 109 errors like that.
mdlesk
  •  mdlesk
  • 71.6% (Friendly)
  • YAF Forumling Topic Starter
2008-11-11T17:27:25Z
Make sure you copied one of the webconfig files from the webconfig directory to the root of the web application. Rename it to web.config and all it should build fine. Without this step, nothing will build as it contains all of the references.
mdlesk
  •  mdlesk
  • 71.6% (Friendly)
  • YAF Forumling Topic Starter
2008-11-11T17:30:55Z
You can try downloading from this location:

DLESKTECH ShoutBox 
midwestSS
2008-11-11T17:31:19Z
thanks!
getting closer
Error 1 The file '/YetAnotherForum.NET/pages/ShoutBox.ascx.cs' does not exist. C:\Documents and Settings\me\Desktop\yaf\YAF-v1.9.3-RC2-SRC\YetAnotherForum.NET\pages\ShoutBox.ascx 1
midwestSS
2008-11-11T17:48:31Z
ok i tried it again, and it looks like all the dll files rebuilt. do i need to re copy all the new dll's in place, or just one, two, etc?
i only got one error about it mismatching what was in my temp files, but it completed the build.
mdlesk
  •  mdlesk
  • 71.6% (Friendly)
  • YAF Forumling Topic Starter
2008-11-11T17:56:06Z
Can you post what you have in your Forum.ASCX file? The reference to DLESKTECH control should not be pointing to the pages directory.
midwestSS
2008-11-11T18:04:11Z
sure.
i thought i had it right. so i was gonna load it on the site.
i went to run the sql script, which is where im usually much better, but i got these errors.
im loopy this late at night right now..so..
Msg 170, Level 15, State 1, Line 11
Line 11: Incorrect syntax near '('.
Msg 170, Level 15, State 1, Procedure yaf_DLESKTECH_ShoutBox_GetMessages, Line 3
Line 3: Incorrect syntax near '('.



<%@ Register TagPrefix="YAF" TagName="ForumActiveDiscussion" Src="../controls/ForumActiveDiscussion.ascx" %>
is what i had in that file btw
vash
  •  vash
  • 100% (Exalted)
  • YAF Commander
2008-11-12T03:54:30Z
how can I make the smileys work? the hyperlink is already working 🙂
mdlesk
  •  mdlesk
  • 71.6% (Friendly)
  • YAF Forumling Topic Starter
2008-11-12T04:08:39Z
vash wrote:

how can I make the smileys work? the hyperlink is already working 🙂



Can you send me a screenshot of what your shoutbox looks like. So I can see the exact issue.
vash
  •  vash
  • 100% (Exalted)
  • YAF Commander
2008-11-12T04:29:05Z
Hi,

I was able to display the smilies. I just changed the following code

<asp:ImageButton ImageUrl='<%# "/images/emoticons/" + Eval("Icon") %>' OnClientClick='<%# FormatSmiliesOnClickString(Eval("Code").ToString(),Eval("Icon").ToString()) %>' runat="server" />


to this one

<asp:ImageButton ImageUrl='<%#"../images/emoticons/" + Eval("Icon")%>' OnClientClick='<%# FormatSmiliesOnClickString(Eval("Code").ToString(),Eval("Icon").ToString()) %>' runat="server" />


The smileys are now displayed on the upper panel. Now my problem is if I click any of the smileys, the corresponding text is not written in the text box. So I have to know by heart the equivalent text value and manually type it in the text box.
midwestSS
2008-11-12T06:09:51Z
ok i got it working!! yay!
ok BUT.. i wanted to cut down the amount of smilies shown cuz it was hideous. made my shoutbox look SILLY.
www.silveradoss.net  check it out.. how can i get rid of all those extra smiley boxes???
i changed the shoutbox.ascx file to point to another location for smiley files and only put a few smilies in there.
midwestSS
2008-11-12T09:42:00Z
1) Thank you so much for this!!
2) can i turn off the smileys from showing on the shoutbox
3) How does one add a refresh button? each attempt i tried rendered the forum useles and i had to back out.
4) Can I apply access masks to the shoutbox so you have to be a member to READ it?
midwestSS
2008-11-12T18:10:03Z
i dont know if I compiled something incorrectly, or what, BUT.. with this shoutbox you can use the forum tags for things like IMG to display images in posts.. but as soon as people start doing that, you start gettting errors in the browser... out of memory at line .......... type messages.
so you all tell me.. did i compile wrong? if i did, can someone upload properly compiled .dll files?
one more suggestion? YAF allows you to prune messages or forums... it would be ideal to also add a control into the admin section to allow you to prune the messages in the shoutbox, instead of going into the database's table like i did to clean it out.
mdlesk
  •  mdlesk
  • 71.6% (Friendly)
  • YAF Forumling Topic Starter
2008-11-12T18:16:33Z
I am currently rewriting the control to be purely compiled in a DLL. The only thing that will be necessary is to create the DB items in SQL and add the references to the page. It should equal to about 4 lines of code total. By the way the next version will have admin controls to perform advanced functionality. It might be a few days before I can get it released though.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved