YAFLogo

khoacoi
  • khoacoi
  • 50.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
Hi YetAnotherForum,
I'm a new member.
I've been created file web.config (copy from default.config)
<?xml version="1.0"?>
<configuration>
	<configSections>
		<section name="yafnet" type="yaf.SectionHandler,yaf"/>
    <section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" />
	</configSections>

	<yafnet configSource="yafnet.config"/>
	<rewriter configSource="urlrewriter.config"/>
 
	<system.web>
    <httpModules>
      <add type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" name="UrlRewriter" />
    </httpModules>    
		<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
		<compilation defaultLanguage="c#" debug="false"/>
		<pages enableEventValidation="false" validateRequest="false" smartNavigation="false"/>
		<authentication mode="Forms">
			<forms name=".YAFNET_Authentication" timeout="525600" />
		</authentication>
		<customErrors defaultRedirect="error.aspx" mode="RemoteOnly"/>
		<!--trace enabled="true" pageOutput="true"/-->
		<xhtmlConformance mode="Legacy"/></system.web>
</configuration>

and modified yatnet.config
<yafnet>
	<connstr>user id=phaplua_forum;pwd=password;data source=mssql12.ixwebhosting.com;initial catalog=phaplua_forum;timeout=90</connstr>
	<uploaddir>~/upload/</uploaddir>
	<boardid>1</boardid>
	<!-- Enable URL Rewriting -->
	<enableurlrewriting>false</enableurlrewriting>
	<!--logtomail>email=;server=;user=;pass=;</logtomail-->
	<!--categoryid>1</categoryid-->
	<!-- Enable these to use a custom user class "provider" -->
	<!--CustomUserAssembly>TinyGecko.YAFIntegration.dll</CustomUserAssembly>
    <CustomUserClass>TinyGecko.YAFIntegration.yafUserClass</CustomUserClass-->
</yafnet>

but I still have problem in Application:
<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

Please help me!
Thanks !!
Sponsor

mtranda
  • mtranda
  • 51.8% (Neutral)
  • YAF Forumling
15 years ago
Can you please modify your web.config file to CustomErrors="Off" instead of "RemoteOnly" and then mention what the error is ? Right now the actual error is hidden by the default error page and it's not relevant.
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button