YAFLogo

test2005
  • test2005
  • 100% (Exalted)
  • YAF MVP Topic Starter
2008-09-05T00:44:05Z
Right...this problem is SOLVED....but I wanted to post it here so that someone later on will find a reference.

Thanks to MEK for answering my "cries of help"! ;)

So..download the latest v1.9.3.3 BETA. Use the new yetanotherforum.net.vs2008.sln file to kick things off (thanks Jaben!) and everything is fine.

Create a blank DB in SQL then compile the site and run locally. Run through the /install/default.aspx procedure for a brand new forum, everything fine. Do some minor setup..a no brainer.

FTP the local site to my server. Create a backup (.bak) for the DB and upload that. Perform a restore on the SQL instance on the server. Assign the correct SQL user to the new DB and give them FULL PERMISSIONS.

Open IE, nav to my test domain, presto! It works.

Now the interesting part. You can view the default.aspx pages, drill down into the forums, but the instant I tried to access anything calling the "yaf_prov_Profile" table, I'd get...

The SELECT permission was denied on the object 'yaf_prov_Profile', database 'yafnet', schema 'dbo'.

I spent all day trying to nail this down. Re-assign the user, re-applied the permission settings, created new accounts, created new databases, nothing worked!! ALWAYS that same, typically "Micro$oft-unhelpful", error!!!

In desperation, I Googled "full SQL DB control" and came across and article that said assigning "sysadmin" rights for my SQL User to the DB will solve all of my problems. And it did.

System is working. Not sure how secure it is, but it works.

Funny thing is, I MANUALLY set "full permissions" to each and every object. I still got this "The SELECT permission.." error. But ONLY on table "yaf_prov_Profile" and no others!

MEK seems to think, and I agree, that my SQL instance may be "flawed". I've never had any problems of any kind with it. It runs my v1.9.2 YAF perfectly, never had this issue.

Can anyone shed a nit of light as to WHY!!!!!!!

:)


.....the man in black fled across the desert..........and the gunslinger followed.....

Sponsor
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
2008-09-06T01:09:41Z
Profile provider actively alters the columns on the table... E.g. add column stuff.

That's probably where the permission stuff is having issues.


UserPostedImage