Nico
  •  Nico
  • 98% (Exalted)
  • YAF Commander Topic Starter
2008-08-20T16:51:48Z
:shock: BEWARE :!:

If you want to avoid problems with your not english speaking users.

You have to MODIFY ALL .XML FILES in 'languages' directory (except 'english.xml').

Open one by one your .xml and proceed as follows:

- find '<page name="DEFAULT">',
- go to the following tag: '<Resource tag="STATS_LASTPOST">'

If you check in 'english.xml', you will see that only one parameter is provided: {0}
<Resource tag="STATS_LASTPOST">Last post {0} by</Resource>

The problem is that in other .xml files, another parameter {1} has been put after 'by'. YOU MUST DELETE THIS {1} or you will have problem once you will go back to the main page to see the forums after having modified your language setting.

For most of them it is easy as the language structure is the same as in English, even if you don't understand the meaning. For the Chinese one, I provide you the correct translation as soon as I get it.


http://forum.yetanotherf...e-for-xml-bug.aspx#27101 

I will also put the Turkish as soon as I get it. Others are easy to modify.
Sponsor
Nico
  •  Nico
  • 98% (Exalted)
  • YAF Commander Topic Starter
2008-08-20T22:15:26Z
Same problem with 'STATS_LASTMEMBER', always in DEFAULT.:!:

No parameter within the english.xml: 'The newest member is'.

You have to delete the {0} into the other languages .xml file (except for German and Persian which are already ok). For Hebrew I don't know, need a translator.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved