YAFLogo

matejka
  • matejka
  • 50.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
Hi,
I'm installing latest version of YAF and I have a following problem. Installation step 4 of 5 fails with message "Could not find stored procedure yaf_system_initialize". I've checked the database and this procedure exists and it's possible to execute it without error.

I guess that the problem is caused by the fact that I don't install YAF into dbo schema, but into schema "lsyaf" (I don't have enough rights to dbo schema). I changed the sql scripts in /install dir to work with "lsyaf" schema instead of "dbo" and it works smoothly -> all the tables, procs etc have been created.

Finally I think the problem is in default.aspx.cs where procedure yaf_system_initialize is called, but without schema specification, so dbo is probably used and it causes the error. I changed this code to work with my schema "lsyaf" but it doesn't work, there is still error message mentioned in first paragraph. I've also tried to execute this procedure manually in the database, it worked ok, but probably something is missing, because if I want to load initial forum page (/forum/default.aspx) the browser redirects me to install page.

Can anybody help me with this problem?

thanks


Jiri Matejka
Sponsor

Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
15 years ago
It's a problem -- which is fixed in v1.9.3.
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button