dizzy0ny
2008-09-26T22:44:06Z
I have loaded the VS2008 project. It did it's typical conversion stuff..
I now went on to try and compile this project and receiving a large number of errors pertaining to the the pages located in \YetAnotherForum.Net\pages. these errors all complain about the YAF server tag being used in those pages. Here is an example

Error	142	Unknown server tag 'YAF:LocalizedLabel'.	D:\Projects\Websites\YetAnotherForum.NET\controls\ProfileYourAccount.ascx	7	


I also tried building the controls project itself first and verified that the new dll is copied to the bin directory of the website project. That did not help.

I am not sure, but always thought that when you are suing custom controls, the must be defined in the aspx page itself. these pages do not seem to do that and that may be why the error is occurring. Any thoughts?
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-09-26T23:08:53Z
It's your web.config... needs to include the YAF.* namespaces. Look at the web.config provided in the YAF v1.9.3 project.
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-09-26T23:12:02Z
juanp2 wrote:

Not sure if this would be on topic here, but a question for the developers. Why did you choose to go with writing custom user-role providers rather than just building off the built in ASP.NET ones?


Backwards compatibility with older YAF was impossible with the ASP.NET providers.

But you are FREE to use them if you want... it's not like the custom YAF providers are required. (only if you need backward compatibility.)
dizzy0ny
2008-09-27T00:27:18Z
Jaben wrote:

It's your web.config... needs to include the YAF.* namespaces. Look at the web.config provided in the YAF v1.9.3 project.


Ah..beautiful. I assumed the web.config that was part of the source would have the appropriate settings. I basically cut and paste the settings in dev-recommended-web.config to web.config and now i am able to compile.

I also copied that to my main website that is hosting the YAF forum and of root for app.config, db.config, URLRewriter.config, mail.config.

I get further but then i try to browser to the forum i see this.


Quote:

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Unknown server tag 'YAF:Forum'.

Source Error:


Line 18: <img src="~/images/YAFLogo.jpg" runat="server" alt="YetAnotherForum" id="imgBanner" /><br/>
Line 19: <form id="form1" runat="server" enctype="multipart/form-data">
Line 20: <YAF:Forum runat="server" ID="forum"></YAF:Forum>
Line 21: </form>
Line 22: </body>


Source File: /forum/YetAnotherForum.NET/Default.aspx Line: 20

dizzy0ny
2008-09-27T00:29:21Z
that should read 'I also copied that to my main website that is hosting the YAF forum and ofcourse changed the root for entries that references app.config, db.config, URLRewriter.config, mail.config.'
dizzy0ny
2008-09-27T07:19:22Z
An thoughts on the above issue? I most likely is related to the web.config again i imagine, but i cant figure out why. All the dlls have been copied to the main website's bin.
I merged the YAF web.config with the main sites config. But still i am getting this error. I am wondering which line in the Web.Config helps the app 'know' about 'YAF:Forum' control?
dizzy0ny
2008-09-27T09:06:14Z
In previous versions of yaf, we had a "root" element that allowed us to indicate where the root of YAF files were. In the latest beta version, where does this element go and does it still exist?
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer Topic Starter
2008-09-27T21:58:46Z
You need to copy the /App_Code directory to the application root including the .cs files in there.
ash360
2008-09-28T15:41:16Z
hi folks

where can i download 1.9.3 RC1 from

thank you in advanced
Visit my Forums: FORUMZ360.com 
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2008-09-29T06:27:19Z
Patience, my young padawan.

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
ash360
2008-09-30T09:22:02Z
patience it is
Visit my Forums: FORUMZ360.com 
VagyokC4
2008-10-04T09:25:19Z
Jaben wrote:

YAF v1.9.3 BETA ( Dated 7/3/2008 )

BETA SOFTWARE: USE AT YOUR OWN RISK

July 3rd Update:

Jaben: Added Admin Password Reset function for User Editor.



Where do I find this functionality. I am unable to find in the User Control Panal... (I simply merged my older source version with the latest release)
I can find the new UserControl in the source, but the site doesn't seem to be calling it.

Any help would be appreciated.
VagyokC4
2008-10-04T09:34:14Z
VagyokC4 wrote:

Jaben wrote:

YAF v1.9.3 BETA ( Dated 7/3/2008 )

BETA SOFTWARE: USE AT YOUR OWN RISK

July 3rd Update:

Jaben: Added Admin Password Reset function for User Editor.



Where do I find this functionality. I am unable to find in the User Control Panal... (I simply merged my older source version with the latest release)
I can find the new UserControl in the source, but the site doesn't seem to be calling it.

Any help would be appreciated.



Ok,

I tried to copy the source over again... (I think there was a problem with the merge functionality)

Now I see more new items, and when compiling I get the following error:

Error 1 'YAF.Controls.PMView' does not contain a definition for 'FromQueryString' G:\!DEV\DCLV\!YAF\YetAnotherForum.NET\pages\cp_pm.ascx.cs 63 24 G:\...\YetAnotherForum.NET\

Any ideas how to fix this so I can compile???
VagyokC4
2008-10-04T09:45:38Z
VagyokC4 wrote:

VagyokC4 wrote:

Jaben wrote:

YAF v1.9.3 BETA ( Dated 7/3/2008 )

BETA SOFTWARE: USE AT YOUR OWN RISK

July 3rd Update:

Jaben: Added Admin Password Reset function for User Editor.



Where do I find this functionality. I am unable to find in the User Control Panal... (I simply merged my older source version with the latest release)
I can find the new UserControl in the source, but the site doesn't seem to be calling it.

Any help would be appreciated.



Ok,

I tried to copy the source over again... (I think there was a problem with the merge functionality)

Now I see more new items, and when compiling I get the following error:

Error 1 'YAF.Controls.PMView' does not contain a definition for 'FromQueryString' G:\!DEV\DCLV\!YAF\YetAnotherForum.NET\pages\cp_pm.ascx.cs 63 24 G:\...\YetAnotherForum.NET\

Any ideas how to fix this so I can compile???




Ok.. Ignore these last few posts... The problem was with WinRar trying to merge my older source with the newer source... Once I extracted to new folder, and then merged the files all seems to compile 🙂 Sorry for the posts...
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved