YAFLogo

guest
  • guest
  • Guest Topic Starter
14 years ago
http://www.gator40-8.com/yetanotherforum/default.aspx 

1. I replcaed the Logo with one of my own. I would like to place a couple links in the same section over to the right that would give users the option to navigate to the main site. I have tried this in the Default.aspx using position absolute styles, align tags, and non breaking spaces and nothing has worked.

2. I also want to put an Adsense ad up top just like this forum does, but I do not know what file to put it in, and I'm not sure if I can get it aligned right given my troubles with item 1 above.

If anyone has the time to point me in the right direction, please let me know. Thanks in advance, and Happy Holidays!

Sponsor

Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
14 years ago
1. Not sure what you are after here. I suggest trying a table.

2. Modify the /pages/forum.ascx file.

Before the I have this code:


<table border="0" cellpadding="0" cellspacing="0" width="100%">
<tr><td valign="middle">
<yaf:PageLinks runat="server" ID="PageLinks" />
<div id="Welcome" runat="server">
    <div id="divTimeNow">
        <asp:Label ID="TimeNow" runat="server" /></div>
    <div id="divTimeLastVisit">
        <asp:Label ID="TimeLastVisit" runat="server" /></div>
    <div id="divUnreadMsgs">
        <asp:HyperLink runat="server" ID="UnreadMsgs" Visible="false" /></div>
</div>
</td>
<td align="right" valign="top">
<!-- ADSENSE CODE -->
</td></tr></table>

Happy Holidays to you as well.

guest
  • guest
  • Guest Topic Starter
14 years ago
Jaben wrote:

1. Not sure what you are after here. I suggest trying a table.

2. Modify the /pages/forum.ascx file.

Before the I have this code:


<table border="0" cellpadding="0" cellspacing="0" width="100%">
<tr><td valign="middle">
<yaf:PageLinks runat="server" ID="PageLinks" />
<div id="Welcome" runat="server">
    <div id="divTimeNow">
        <asp:Label ID="TimeNow" runat="server" /></div>
    <div id="divTimeLastVisit">
        <asp:Label ID="TimeLastVisit" runat="server" /></div>
    <div id="divUnreadMsgs">
        <asp:HyperLink runat="server" ID="UnreadMsgs" Visible="false" /></div>
</div>
</td>
<td align="right" valign="top">
<!-- ADSENSE CODE -->
</td></tr></table>

Happy Holidays to you as well.

Thanks I'll give it a shot.

guest
  • guest
  • Guest Topic Starter
14 years ago
Thanks that worked. Now I have to figure out how to make it display the same for all users.
pebbleplace
14 years ago
Hi Jaben -

I used your example above and AdSense appears to be working fine on the page listing the forums, so you know where this is going, right? 🙂 I think we need to add code to:

posts.ascx

topics.ascx

Obviously I can't just copy and paste the same code since it has the "last login" info. I'm perfectly happy putting the AdSense right in the exact same location (upper right). The 468x60 banner seems to fit okay, so that's probably what I'll run with. Could you be kind enough to say whether or not this would work:

<table border="0" cellpadding="0" cellspacing="0" width="100%">
<td align="right" valign="top">
<!-- ADSENSE CODE -->
</td></tr></table>

Assuming something that simple would work, where should I place it on the "posts" & "topics" .ascx pages?

Thank you, John.