YAFLogo

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
5 days ago
Regarding the error, it should not happen. Can you check inside the database what column type the column Description and Source is inside the yaf_Eventlog table?

Quote:

I have one of my members who cannot login. I tried it on my computer, I can log in with my credentials fine, but when I try with his, using the same username and password as before the upgrade,



The password should work after the upgrade. But only if you migrate the membership settings from the web.config as described in the documentation...

https://github.com/YAFNET/YAFNET/wiki/Web.Config-changes 
eutychus
  • eutychus
  • 100% (Exalted)
  • YAF Lover Topic Starter
5 days ago
Originally Posted by: tha_watcha 

Regarding the error, it should not happen. Can you check inside the database what column type the column Description and Source is inside the yaf_Eventlog table?

Quote:

I have one of my members who cannot login. I tried it on my computer, I can log in with my credentials fine, but when I try with his, using the same username and password as before the upgrade,



The password should work after the upgrade. But only if you migrate the membership settings from the web.config as described in the documentation...

https://github.com/YAFNET/YAFNET/wiki/Web.Config-changes 



Still throws the error. Here's my web.config:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="rewriter" type="YAF.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, YAF.UrlRewriter" requirePermission="false" />
  </configSections>
  <connectionStrings configSource="db.config" />
  <appSettings configSource="app.config" />
  <rewriter configSource="URLRewriter.config" />
  <system.net>
    <mailSettings>
      <smtp configSource="mail.config" />
    </mailSettings>
  </system.net>
  <system.web>
    <httpRuntime targetFramework="4.8" />
    <customErrors defaultRedirect="Error.aspx" mode="Off" />
    <globalization culture="en-US" uiCulture="en" requestEncoding="UTF-8" responseEncoding="UTF-8" fileEncoding="UTF-8" />
    <!--<globalization culture="en-US" uiCulture="en"  fileEncoding="iso-8859-1" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>-->
   
    <compilation  debug="false" targetFramework="4.8" />
    <httpHandlers>
      <add verb="GET" path="Resource.ashx" type="YAF.Core.Handlers.ResourceHandler, YAF.Core" />
    </httpHandlers>
    <httpModules>
      <add name="UrlRewriter" type="YAF.UrlRewriter.RewriterHttpModule,YAF.UrlRewriter" />
    </httpModules>
    <pages clientIDMode="AutoID">
      <controls>
        <!-- Default: use non-dynamic (compiled classes) in YAF -->
        <add tagPrefix="YAF" namespace="YAF.Web.Controls" assembly="YAF.Web" />
        <add tagPrefix="YAF" namespace="YAF.Configuration" />
        <add tagPrefix="YAF" namespace="YAF" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_menu.ascx" tagName="iadb_menu" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_create_header.ascx" tagName="iadb_create_header" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_create_metadata.ascx" tagName="iadb_create_metadata" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_redirectUpdates.ascx" tagName="iadb_redirectUpdates" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_skyscraper_ad.ascx" tagName="iadb_skyscraper_ad" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_square_ad.ascx" tagName="iadb_square_ad" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_getExtraBox.ascx" tagName="iadb_getExtraBox" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_listingheader.ascx" tagName="iadb_listingheader" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/entry_header.ascx" tagName="iadb_entry_header" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_characters.ascx" tagName="iadb_characters" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_caricatures.ascx" tagName="iadb_caricatures" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_credits.ascx" tagName="iadb_credits" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_synopsis.ascx" tagName="iadb_synopsis" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_broadcasters.ascx" tagName="iadb_broadcasters" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iad_runtime.ascx" tagName="iadb_runtime" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iad_prodno.ascx" tagName="iadb_prodno" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_mpaanumber.ascx" tagName="iadb_mpaanumber" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_mpaarating.ascx" tagName="iadb_mpaarating" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_tech_specs.ascx" tagName="iadb_tech_specs" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_video_index.ascx" tagName="iadb_video_index" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_music.ascx" tagName="iadb_music" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_awards.ascx" tagName="iadb_awards" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_broadcasters.ascx" tagName="iadb_broadcasters" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_distributors.ascx" tagName="iadb_distributors" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_links.ascx" tagName="iadb_links" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_connections.ascx" tagName="iadb_connections" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_notes.ascx" tagName="iadb_notes" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_television.ascx" tagName="iadb_television" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_hashtags.ascx" tagName="iadb_hashtags" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls_sub/iadb_login_screen.ascx" tagName="iadb_login_screen" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls_sub/get_right_column_title.ascx" tagName="iadb_get_right_column_title" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/video_entries.ascx" tagName="iadb_video_entries" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_skyscraper_ad.ascx" tagName="iadb_skyscraper_ad" />

      </controls>
      <namespaces>
        <add namespace="YAF" />
        <add namespace="YAF.Core" />
        <add namespace="YAF.Web.Controls" />
        <add namespace="YAF.Types.Interfaces" />
        <add namespace="YAF.Types" />
        <add namespace="System.Web.Helpers" />
        <add namespace="System.Web.Mvc" />
        <add namespace="System.Web.Mvc.Ajax" />
        <add namespace="System.Web.Mvc.Html" />
        <add namespace="System.Web.Optimization" />
        <add namespace="System.Web.Routing" />
        <add namespace="System.Web.WebPages" />
      </namespaces>
    </pages>
   
    <webServices>
      <protocols>
        <add name="HttpGet" />
        <add name="HttpPost" />
      </protocols>
    </webServices>
  </system.web>
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    <modules>
      <remove name="UrlRewriter" />
      <add name="UrlRewriter" type="YAF.UrlRewriter.RewriterHttpModule,YAF.UrlRewriter" preCondition="managedHandler" />
    </modules>
    <handlers>
      <add name="YafHandler" preCondition="integratedMode" verb="GET" path="Resource.ashx" type="YAF.Core.Handlers.ResourceHandler, YAF.Core" />
      <add name="YafSitemapHandler" path="Sitemap.xml" verb="*" type="YAF.Core.Handlers.SiteMapHandler, YAF.Core" preCondition="integratedMode" />
      <add name="FileUploader" path="FileUploader.ashx" verb="*" type="YAF.Core.Handlers.FileUploader, YAF.Core" preCondition="integratedMode" />
    <remove name="ExtensionlessUrlHandler-Integrated-4.0" /><remove name="OPTIONSVerbHandler" /><remove name="TRACEVerbHandler" /><add name="ExtensionlessUrlHandler-Integrated-4.0" path="*." verb="*" type="System.Web.Handlers.TransferRequestHandler" preCondition="integratedMode,runtimeVersionv4.0" /></handlers>
    <staticContent>
      <remove fileExtension=".woff" />
      <remove fileExtension=".woff2" />
      <mimeMap fileExtension=".woff" mimeType="application/x-font-woff" />
      <mimeMap fileExtension=".woff2" mimeType="application/font-woff2" />
      <mimeMap fileExtension=".webmanifest" mimeType="application/manifest+json" />
    </staticContent>
    <caching>
      <profiles>
        <add extension=".png" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".gif" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".jpg" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".js" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".css" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".ico" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".axd" kernelCachePolicy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
      </profiles>
    </caching>
    <rewrite>
      <rules>
        <clear />
        <rule name="Redirect to https" stopProcessing="true">
          <match url=".*" />
          <conditions>
            <add input="{HTTPS}" pattern="off" ignoreCase="true" />
          </conditions>
          <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Permanent" appendQueryString="false" />
        </rule>
      </rules>
    </rewrite>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Diagnostics.DiagnosticSource" publicKeyToken="CC7B13FFCD2DDD51" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-8.0.0.1" newVersion="8.0.0.1" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Bcl.AsyncInterfaces" publicKeyToken="CC7B13FFCD2DDD51" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-8.0.0.0" newVersion="8.0.0.0" />
      </dependentAssembly>
      <probing privatePath="bin" />
      <dependentAssembly>
        <assemblyIdentity name="Antlr3.Runtime" publicKeyToken="EB42632606E9261F" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-3.5.0.2" newVersion="3.5.0.2" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="WebGrease" publicKeyToken="31BF3856AD364E35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-1.6.5135.21930" newVersion="1.6.5135.21930" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" />
        <bindingRedirect oldVersion="0.0.0.0-13.0.0.0" newVersion="13.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-4.2.2.0" newVersion="4.2.2.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Security.OAuth" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-4.2.2.0" newVersion="4.2.2.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Security" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-4.2.2.0" newVersion="4.2.2.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Security.Cookies" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-4.2.2.0" newVersion="4.2.2.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Extensions.Primitives" publicKeyToken="ADB9793829DDAE60" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-6.0.0.0" newVersion="6.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Threading.Tasks.Extensions" publicKeyToken="cc7b13ffcd2ddd51" />
        <bindingRedirect oldVersion="0.0.0.0-4.2.0.1" newVersion="4.2.0.1" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Memory" culture="neutral" publicKeyToken="cc7b13ffcd2ddd51" />
        <bindingRedirect oldVersion="0.0.0.0-4.0.1.2" newVersion="4.0.1.2" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Runtime.CompilerServices.Unsafe" publicKeyToken="b03f5f7f11d50a3a" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-6.0.0.0" newVersion="6.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="WebGrease" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-1.6.5135.21930" newVersion="1.6.5135.21930" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Antlr3.Runtime" publicKeyToken="eb42632606e9261f" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-3.5.0.2" newVersion="3.5.0.2" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Host.SystemWeb" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-4.2.2.0" newVersion="4.2.2.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Web.Infrastructure" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-2.0.1.0" newVersion="2.0.1.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Http.WebHost" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-5.2.9.0" newVersion="5.2.9.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Http" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-5.2.9.0" newVersion="5.2.9.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-5.3.0.0" newVersion="5.3.0.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>

and my app.config:

<appSettings>
 <add key="YAF.BoardID" value="1" />
 <add key="YAF.DatabaseObjectQualifier" value="yaf_" />
 <add key="YAF.DatabaseOwner" value="dbo" />
 <add key="YAF.ConnectionStringName" value="yafnet" />
 <add key="YAF.MobileUserAgents" value="iphone,ipad,midp,windows ce,windows phone,android,blackberry,opera mini,mobile,palm,portable,webos,htc,armv,lg/u,elaine,nokia,playstation,symbian,sonyericsson,mmp,hd_mini" />
 <add key="YAF.FileRoot" value="~/forum" />
 <add key="YAF.AppRoot" value="~/forum" />
 <add key="YAF.EnableURLRewriting" value="true" />
 <add key="YAF.BaseScriptFile" value="forum.aspx" />
 <add key="YAF.ForceScriptName" value="forum.aspx" />
  <add key="getRedlineText" value ="Note: items in red are not attached to a title and should be deleted." />
  <add key="getSorryText" value="Sorry, you do not have permission to view this page."/>
 <add key="webpages:Version" value="3.0.0.0" />
 <add key="webpages:Enabled" value="false" />
  <add key="YAF.LegacyMembershipHashAlgorithmType" value="SHA1" />
 <add key="ValidationSettings:UnobtrusiveValidationMode" value="None" />
  <add key="YAF.LegacyMembershipPasswordFormat" value="Hashed" />
  <add key="YAF.LegacyMembershipHashCase" value="Upper" />
  <add key="YAF.LegacyMembershipHashHex" value="true" />
  
</appSettings>
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
5 days ago
You posted the current web.config. can you post the web.config before the upgrate to 3.x.x?
eutychus
  • eutychus
  • 100% (Exalted)
  • YAF Lover Topic Starter
5 days ago
Here's the last one we had before we updated:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="rewriter" type="YAF.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, YAF.UrlRewriter" requirePermission="false" />
  </configSections>
  <connectionStrings configSource="db.config" />
  <appSettings configSource="app.config" />
  <rewriter configSource="URLRewriter.config" />
  <system.net>
    <mailSettings>
      <smtp configSource="mail.config" />
    </mailSettings>
  </system.net>
  <system.web>
    <httpRuntime targetFramework="4.7.2" />
    <customErrors defaultRedirect="Error.aspx" mode="Off" />
    <!--  GLOBALIZATION
          This section sets the globalization settings of the application. 
          Utf-8 is not supported on Netscape 4.x 
          If you need Netscape compatibility leave iso-8859-1.
          UTF-8 is recommended for complex languages
    -->
    <globalization culture="en-US" uiCulture="en" requestEncoding="UTF-8" responseEncoding="UTF-8" fileEncoding="UTF-8" />
    <!--<globalization culture="en-US" uiCulture="en"  fileEncoding="iso-8859-1" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>-->
    <authentication mode="Forms">
      <forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies" />
    </authentication>
    <!-- COMPILATION
    * Set debug to "true" to test out the system in development 
    * Set optimizeCompilation to "true" for *MUCH* faster application pool
      restarts on larger .NET systems. But, please read and understand the caveats
      before enabling this settings:
      http://blogs.msdn.com/b/davidebb/archive/2009/04/15/a-new-flag-to-optimize-asp-net-compilation-behavior.aspx             
    -->
    <compilation debug="true" targetFramework="4.7.2" />
    <httpHandlers>
      <add verb="GET" path="Resource.ashx" type="YAF.Core.Handlers.ResourceHandler, YAF.Core" />
    </httpHandlers>
    <httpModules>
      <add name="YafTaskModule" type="YAF.Core.TaskModule, YAF.Core" />
      <add name="UrlRewriter" type="YAF.UrlRewriter.RewriterHttpModule,YAF.UrlRewriter" />
    </httpModules>
    <pages clientIDMode="AutoID">
      <controls>
        <add tagPrefix="asp" namespace="System.Web.UI.HtmlControls" assembly="System.Web" />
        <!-- Default: use non-dynamic (compiled classes) in YAF -->
        <add tagPrefix="YAF" namespace="YAF.Web.Controls" assembly="YAF.Web" />
        <add tagPrefix="YAF" namespace="YAF.Configuration" />
        <add tagPrefix="YAF" namespace="YAF" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_menu.ascx" tagName="iadb_menu" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_create_header.ascx" tagName="iadb_create_header" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_create_metadata.ascx" tagName="iadb_create_metadata" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_redirectUpdates.ascx" tagName="iadb_redirectUpdates" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_skyscraper_ad.ascx" tagName="iadb_skyscraper_ad" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_square_ad.ascx" tagName="iadb_square_ad" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_getExtraBox.ascx" tagName="iadb_getExtraBox" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_listingheader.ascx" tagName="iadb_listingheader" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/entry_header.ascx" tagName="iadb_entry_header" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_characters.ascx" tagName="iadb_characters" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_caricatures.ascx" tagName="iadb_caricatures" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_credits.ascx" tagName="iadb_credits" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_synopsis.ascx" tagName="iadb_synopsis" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_broadcasters.ascx" tagName="iadb_broadcasters" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iad_runtime.ascx" tagName="iadb_runtime" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iad_prodno.ascx" tagName="iadb_prodno" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_mpaanumber.ascx" tagName="iadb_mpaanumber" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_mpaarating.ascx" tagName="iadb_mpaarating" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_tech_specs.ascx" tagName="iadb_tech_specs" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_video_index.ascx" tagName="iadb_video_index" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_music.ascx" tagName="iadb_music" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_awards.ascx" tagName="iadb_awards" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_broadcasters.ascx" tagName="iadb_broadcasters" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_distributors.ascx" tagName="iadb_distributors" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_links.ascx" tagName="iadb_links" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_connections.ascx" tagName="iadb_connections" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_notes.ascx" tagName="iadb_notes" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_television.ascx" tagName="iadb_television" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_hashtags.ascx" tagName="iadb_hashtags" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls_sub/iadb_login_screen.ascx" tagName="iadb_login_screen" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls_sub/get_right_column_title.ascx" tagName="iadb_get_right_column_title" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/video_entries.ascx" tagName="iadb_video_entries" />
        <add tagPrefix="iadb" src="~/iadb_v2_sys_controls/iadb_skyscraper_ad.ascx" tagName="iadb_skyscraper_ad" />

      </controls>
      <namespaces>
        <add namespace="YAF" />
        <add namespace="YAF.Core" />
        <add namespace="YAF.Web.Controls" />
        <add namespace="YAF.Utils" />
        <add namespace="YAF.Types.Interfaces" />
        <add namespace="YAF.Types" />
        <add namespace="System.Web.Optimization" />
      </namespaces>
    </pages>
    <membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">
      <providers>
        <clear />
        <!-- YAF's ASP.NET Membership Provider is designed to work a bit better with YAF.NET options, but is by no means required.
             But, you will not be able to switch providers after installing your forum. -->
        <add name="YafMembershipProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider" />
        <!-- Uncomment and set as default if you want to use the built-in ASP.NET membership provider. Password Type of "Hashed" requires a machine key. -->
        <!-- If you want to install YAF.NET inside Azure you need to use that Provider. -->
        <!--<add name="AspNetSqlMembershipProvider" applicationName="YetAnotherForum" connectionStringName="yafnet"
             enablePasswordReset="false" enablePasswordRetrieval="true" maxInvalidPasswordAttempts="5"
             minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="5" passwordAttemptWindow="15"<
             passwordFormat="Hashed" requiresQuestionAndAnswer="false" requiresUniqueEmail="true"
             type="System.Web.Security.SqlMembershipProvider" />-->
      </providers>
    </membership>
    <roleManager enabled="true" defaultProvider="YafRoleProvider">
      <providers>
        <clear />
        <!-- YAF's ASP.NET Role Provider is designed to work a bit better with YAF.NET options, but is by no means required.
             But, you will not be able to switch providers after installing your forum. -->
        <add name="YafRoleProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" type="YAF.Providers.Roles.YafRoleProvider" />
        <!-- Uncomment and set as default if you want to use use the built-in ASP.NET role provider. -->
        <!--<add name="AspNetSqlRoleProvider" applicationName="YetAnotherForum" connectionStringName="yafnet"
                     type="System.Web.Security.SqlRoleProvider" />-->
      </providers>
    </roleManager>
    <profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Utils.YafUserProfile">
      <providers>
        <clear />
        <!-- YAF's ASP.NET Profile Provider is designed to work a bit better with YAF.NET options, but is by no means required.
             But, you will not be able to switch providers after installing your forum. -->
        <add name="YafProfileProvider" applicationName="YetAnotherForum" connectionStringName="yafnet" type="YAF.Providers.Profile.YafProfileProvider" />
        <!-- Uncomment and set as default if you want to use use the built-in ASP.NET profile provider. -->
        <!--<add name="AspNetSqlProfileProvider" applicationName="YetAnotherForum" connectionStringName="yafnet"
                     type="System.Web.Profile.SqlProfileProvider" />-->
      </providers>
    </profile>
    <!--  Enable it if your application is hosted in a web farm or cluster (e.g. GoDaddy hosting) or you are using standard ASP.NET providers and encryption. 
          IMPORTANT: DO NOT USE THIS KEY! You need to generate your own machine key via https://yetanotherforum.net/key
    -->
    <!-- <machineKey validationKey="5B169A4270DB7D6A285CF068B81047D1A73A5FDDE9B204254AB86147B061C3C13DB6E84311E98EDFDD7FF50309DB9632A1C573A716CF120535EC3401BF7706D7"
        decryptionKey="910403AE3DEB5DD0AF73911DBB180518144AC983C1C7E7BDEE1CC8B6C74CBEF3"
        validation="HMACSHA256" decryption="AES"/> 
    -->
    <webServices>
      <protocols>
        <add name="HttpGet" />
        <add name="HttpPost" />
      </protocols>
    </webServices>
    
  </system.web>
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    <modules>
      <remove name="YafTaskModule" />
      <remove name="UrlRewriter" />
      <add name="YafTaskModule" type="YAF.Core.TaskModule, YAF.Core" preCondition="managedHandler" />
      <add name="UrlRewriter" type="YAF.UrlRewriter.RewriterHttpModule,YAF.UrlRewriter" preCondition="managedHandler" />
    </modules>
    <handlers>
      <add name="YafHandler" preCondition="integratedMode" verb="GET" path="Resource.ashx" type="YAF.Core.Handlers.ResourceHandler, YAF.Core" />
      <add name="YafSitemapHandler" path="Sitemap.xml" verb="*" type="YAF.Core.Handlers.SiteMapHandler, YAF.Core" preCondition="integratedMode" />
      <add name="FileUploader" path="FileUploader.ashx" verb="*" type="YAF.Core.Handlers.FileUploader, YAF.Core" preCondition="integratedMode" />
    </handlers>
    <staticContent>
      <remove fileExtension=".woff" />
      <remove fileExtension=".woff2" />
      <mimeMap fileExtension=".woff" mimeType="application/x-font-woff" />
      <mimeMap fileExtension=".woff2" mimeType="application/font-woff2" />
    </staticContent>
    <caching>
      <profiles>
        <add extension=".png" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".gif" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".jpg" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".js" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".css" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".ico" policy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
        <add extension=".axd" kernelCachePolicy="CacheUntilChange" varyByHeaders="Browser" location="Client" />
      </profiles>
    </caching>
    <rewrite>
      <rules>
        <clear />
        <rule name="Redirect to https" stopProcessing="true">
          <match url=".*" />
          <conditions>
            <add input="{HTTPS}" pattern="off" ignoreCase="true" />
          </conditions>
          <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Permanent" appendQueryString="false" />
        </rule>
      </rules>
    </rewrite>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <probing privatePath="bin;bin\languages" />
      <dependentAssembly>
        <assemblyIdentity name="Antlr3.Runtime" publicKeyToken="EB42632606E9261F" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-3.5.0.2" newVersion="3.5.0.2" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="WebGrease" publicKeyToken="31BF3856AD364E35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-1.6.5135.21930" newVersion="1.6.5135.21930" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="WebGrease" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-1.6.5135.21930" newVersion="1.6.5135.21930" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Antlr3.Runtime" publicKeyToken="eb42632606e9261f" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-3.5.0.2" newVersion="3.5.0.2" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-13.0.0.0" newVersion="13.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-4.1.1.0" newVersion="4.1.1.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Security" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-4.1.1.0" newVersion="4.1.1.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Extensions.Primitives" publicKeyToken="ADB9793829DDAE60" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-5.0.0.1" newVersion="5.0.0.1" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Memory" culture="neutral" publicKeyToken="cc7b13ffcd2ddd51" />
        <bindingRedirect oldVersion="0.0.0.0-4.0.1.1" newVersion="4.0.1.1" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Runtime.CompilerServices.Unsafe" publicKeyToken="B03F5F7F11D50A3A" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-5.0.0.0" newVersion="5.0.0.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
4 days ago
Okay i think in this case theLegacyMembershipHashCase needs to be set to None

 
 <add key="YAF.LegacyMembershipHashCase" value="None" />
eutychus
  • eutychus
  • 100% (Exalted)
  • YAF Lover Topic Starter
4 days ago
Originally Posted by: tha_watcha 

Okay i think in this case the LegacyMembershipHashCase needs to be set to None

 

 <add key="YAF.LegacyMembershipHashCase" value="None" />



Nope. Still same issue.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
4 days ago
I forgot alsoLegacyMembershipHashHex needs to be changed to false

<add key="YAF.LegacyMembershipHashHex" value="false" />

If it still dont work then only a password reset would help.
eutychus
  • eutychus
  • 100% (Exalted)
  • YAF Lover Topic Starter
4 days ago
Originally Posted by: tha_watcha 

I forgot also LegacyMembershipHashHex needs to be changed to false

<add key="YAF.LegacyMembershipHashHex" value="false" />

If it still dont work then only a password reset would help.



Still the same problem.

It's weird, because I can log in and out just fine, but others cannot. I've tried it with one of my other users credentials and it throws that error, yet when I log in with mine, it works fine. I'm having a few of them go through and reset their passwords to see if that helps. I'll report back as soon as I hear from them.
eutychus
  • eutychus
  • 100% (Exalted)
  • YAF Lover Topic Starter
4 days ago
Okay, I'm wondering if it may have something to do with the way it handles roles. That would explain why it's not happening to me as the admin and it is to others. Because on one of may pages, I'm now getting the error:The Role Manager feature has not been enabled.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 days ago
To address the error, can you check the datatypes of the event log columns in the admin interface? Go to Admin > Database > Run SQL Query run

SELECT DATA_TYPE, CHARACTER_MAXIMUM_LENGTH FROM INFORMATION_SCHEMA.COLUMNS WHERE TABLE_NAME = 'yaf_Eventlog' AND COLUMN_NAME = 'Description'

and

SELECT DATA_TYPE, CHARACTER_MAXIMUM_LENGTH FROM INFORMATION_SCHEMA.COLUMNS WHERE TABLE_NAME = 'yaf_Eventlog' AND COLUMN_NAME = 'Source'
eutychus
  • eutychus
  • 100% (Exalted)
  • YAF Lover Topic Starter
3 days ago
RowNumber,DATA_TYPE,CHARACTER_MAXIMUM_LENGTH
"1","nvarchar","100"

RowNumber,DATA_TYPE,CHARACTER_MAXIMUM_LENGTH
"1","nvarchar","100"

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 days ago
Thats odd. It should not be 100 for the Description. This will cause exceptions everytime something is logged. As quick fix execute on the same page the command...

alter table [{databaseOwner}].[{objectQualifier}Eventlog] alter column [Description] nvarchar(max)
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 days ago
Originally Posted by: eutychus 

Okay, I'm wondering if it may have something to do with the way it handles roles. That would explain why it's not happening to me as the admin and it is to others. Because on one of may pages, I'm now getting the error:The Role Manager feature has not been enabled.



No this has nothing to do with roles.

The password is saved as hashed string in the db the format depends on the config settings.

My only guess is that some passwords are stored in a different format than others. This could be caused that in the past the config setting were different.

For me without seeing the data the only solution at the moment is to reset the passwords by the users.
eutychus
  • eutychus
  • 100% (Exalted)
  • YAF Lover Topic Starter
3 days ago
Well, it's taken us thousands of years and cost millions of lives, but I think we've finally got this stable enough to be usable for a bit. My users are reporting that clearing their cookies and resetting their password seems to be doing the trick. And the "Role Manager feature not enabled" turned out to be a programming error of my own. So, I'll let you be for a bit and if I have any other problems I'll open up a new thread because I'm tired of this one. Thank you so much for your time and patience!
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button