YAFLogo

mdavey
  • mdavey
  • 65.2% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.0.2
9 months ago
After getting the sample web app published and running I found multiple errors caused by two missing jquery files -

~\YAF.SampleWebApplication-3.0.2\YAF.SampleWebApplication\Forum\Scripts\jquery.ForumAdminExtensions.js

&

~\YAF.SampleWebApplication-3.0.2\YAF.SampleWebApplication\Forum\Scripts\ jquery.ForumExtensions.js

Once replaced the app works fine except for one major bug - 

When I attempt a new registration and hit the register button I get the following error -

Any ideas?

Thanks

 

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
9 months ago
The Scripts exist in the Source Package. But its possible that there are not published.

Quote:

When I attempt a new registration and hit the register button I get the following error

Oh i think i found the problem the Zip Package was not up do date for the YAF SampleApplication 3.0.2. Re-download the files. now it includes the version 3.0.2

mdavey
  • mdavey
  • 65.2% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.0.2
9 months ago
Now it works.  thanks.

However, I can't get the smtp settings to work.  I have tried with 4 different known good email providers.  Here is an example -

 <smtp deliveryMethod="Network" from="xxx@att.net">
  <network host="smtp.mail.att.net" port="465" password="xxx" userName="xxx@att.net"/>
</smtp>
and another

<smtp deliveryMethod="Network" from="xxx@gmail.net">
  <network host="smtp.gmail.net" port="465" password="xxx" userName="xxx@gmail.net"/>
</smtp> 

I have the email set to the same as the providors above in the admin settings and gmails less secure connection option is turned on in the account.

I keep getting back a reply that the smtp server returned an invalid response.

Any thoughts?

Thanks

 

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
9 months ago
Atleast for gmail the settings are wrong, it should be...

<smtp deliveryMethod="Network" from="xxx@gmail.com">
<network enableSsl="true" defaultCredentials="false" host="smtp.gmail.com" port="587" password="xxx" userName="xxx" />
</smtp>
mdavey
  • mdavey
  • 65.2% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.0.2
9 months ago
The gmail string worked.  That was my preferred provider too!

Thank you so much for your help and patience.