YAFLogo

CliffAgius
  • CliffAgius
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
3 years ago
Hi,

So I have the forum displaying but if I try and start a new post I get the following error:

Quote:

System.Exception

HResult=0x80131500

Message=Unable to load editor class/dll: Telerik.Web.UI.RadEditor,Telerik.Web.UI Exception: Could not load file or assembly 'Telerik.Web.UI' or one of its dependencies. The system cannot find the file specified.

Source=YAF.Web

StackTrace:

at YAF.Web.Editors.RichClassEditor..ctor(String classBinStr) in ~\YAF.Web\Editors\RichClassEditor.cs:line 99

at YAF.Web.Editors.RadEditor..ctor() in ~\YAF.Web\Editors\RadEditor.cs:line 50

at Autofac.Core.Activators.Reflection.ConstructorParameterBinding.Instantiate()

Do we need to purchase and install Telerik controls to use this Forum?

Cliff.

Sponsor

CliffAgius
  • CliffAgius
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
3 years ago
Ok Managed to fix this.

I deleted the RadEditor from the YAF.Web.Editors and removed the references to the editor in the app.config and it all started working.

Looks like I am up and running, take a while but got there in the end.

Great work thanks.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
3 years ago
No you don't have to purchase that editor. That error would only come up in debug mode