YAFLogo

KatjaAusFrankfurt
3 years ago
Last question about Release of the version 2.3 with bootstrap was about 2 years. Will this version be comming soon? Do you plan to release it in some months?
Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 Answer YAF Version: 3.0.3
3 years ago
Originally Posted by: KatjaAusFrankfurt 

Last question about Release of the version 2.3 with bootstrap was about 2 years. Will this version be comming soon? Do you plan to release it in some months?

Sorry it will still take some time. But as you can see this Forum is Already running the New Version. To Find all remaining issues. I work as fast as i can in my free time. The release will be definitively this year.

If you can't wait you can try the beta (At your own risk) from the build Server

https://ci.appveyor.com/project/YAFNET/yafnet/build/artifacts 

KatjaAusFrankfurt
3 years ago
Thank you very much for the answer and for the link!

We decided to use beta version in our company and now I should extend YAF forum with Single Sign On and connect it to our intern system... Is there a source code for the YAF beta somewhere?

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 Answer YAF Version: 3.0.3
3 years ago
KatjaAusFrankfurt
3 years ago
Many thanks for the code! At the moment SSO is ready and we are in the test phase. At the moment the search doesn't work. 0 topics will be found. I found out that the lucene search engine returns no search results. Should search work after YAF installation without any settings in admin area or should I do something for that? I didn't found any setting in admin area for lucene...

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
Originally Posted by: KatjaAusFrankfurt 

Many thanks for the code! At the moment SSO is ready and we are in the test phase. At the moment the search doesn't work. 0 topics will be found. I found out that the lucene search engine returns no search results. Should search work after YAF installation without any settings in admin area or should I do something for that? I didn't found any setting in admin area for lucene...

Well first of all you should upgrade to the latest preview version, which is 2.30 RC3

https://github.com/YAFNET/YAFNET/releases/tag/v2.3.0.0-rc.3 

The search is automatically indexed in the background. You can check the event log if there are any errors with search. But you don't need to configure anything.

KatjaAusFrankfurt
3 years ago
Thank you very much for the quick answer!
KatjaAusFrankfurt
3 years ago
Hallo,

I installed pre release version of the forum and created directory App_Data\search_index manually because it didn't exists. In the first error was "folder not found", because of that I created the folder. But at the moment I have other error in YafSearch.js, in public IndexSearcher GetSearcher():

Lucene.Net.Index.IndexNotFoundException

HResult=0x80070002

Message=no segments* file found in SimpleFSDirectory@C:\YAFNET-2.3.0.0-rc.3\yafsrc\YetAnotherForum.NET\App_Data\search_index lockFactory=NativeFSLockFactory@C:\YAFNET-2.3.0.0-rc.3\yafsrc\YetAnotherForum.NET\App_Data\search_index: files:

Source=Lucene.Net

StackTrace:

at Lucene.Net.Index.SegmentInfos.FindSegmentsFile.Run(IndexCommit commit)

at Lucene.Net.Index.StandardDirectoryReader.Open(Directory directory, IndexCommit commit, Int32 termInfosIndexDivisor)

at Lucene.Net.Index.DirectoryReader.Open(Directory directory)

at Lucene.Net.Search.SearcherManager..ctor(Directory dir, SearcherFactory searcherFactory)

at YAF.Core.Services.YafSearch.GetSearcher() in C:\YAFNET-2.3.0.0-rc.3\yafsrc\YAF.Core\Services\YafSearch.cs:line 440

at YAF.Core.Services.YafSearch.SearchIndex(Int32& totalHits, Int32 forumId, Int32 userId, String searchQuery, String searchField, Int32 pageIndex, Int32 pageSize) in C:\YAFNET-2.3.0.0-rc.3\yafsrc\YAF.Core\Services\YafSearch.cs:line 701

at YAF.Core.Services.YafSearch.SearchPaged(Int32& totalHits, Int32 forumId, Int32 userId, String input, Int32 pageIndex, Int32 pageSize, String fieldName) in C:\YAFNET-2.3.0.0-rc.3\yafsrc\YAF.Core\Services\YafSearch.cs:line 398

at YAF.Core.Controllers.SearchController.GetSearchResults(SearchTopic searchTopic) in C:\YAFNET-2.3.0.0-rc.3\yafsrc\YAF.Core\Controllers\SearchController.cs:line 82

at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ActionExecutor.<>c__DisplayClass6_2.b__2(Object instance, Object[] methodParameters)

at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ActionExecutor.Execute(Object instance, Object[] arguments)

at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ExecuteAsync(HttpControllerContext controllerContext, IDictionary`2 arguments, CancellationToken cancellationToken)

Do you have an idea what should I do? I have attached a screenshot.

 Fehler.PNG You have insufficient rights to see the content.

Greetins

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
Be aware that this pre-release is obsolete. The final version can be downloaded from the downloads page.

If you do a Re-index of the search database the issue should go away. You can do that from the host settings > Search tab.

KatjaAusFrankfurt
3 years ago
Thank you for your great job! I'm very happy about release version of the forum. I've already installed release version and did re-index search database (klicked the red button), but I bekome a problem with the creation of the topics in the forum. Also the search doesn't work. I do something worng, but I don't know what.

Please see screenshots of the problems. I have the same error bei der creation of the topic and by the search.

 Create new topic error.PNG You have insufficient rights to see the content. Fehler im Code.PNG You have insufficient rights to see the content. Search Error.PNG You have insufficient rights to see the content.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
The error is thrown when you search before the index is created. this will be fixed in the next update!

Was the re-index successful, or does it also throw an error? Please check the event log!

And what error are you getting creating a topic?

KatjaAusFrankfurt
3 years ago
re-index was not successful I think, because the folder YetAnotherForum.NET\App_Data\search_index is empty. In bekome nothing after clicking the button, wether error no message about success. By the way, this folder I created by myself because of error that this folder couldn't be find. App_Data folder and search_index have write permissions.

I removed all messages in event log and tried re-index the db again and tried to create a new topic. But no new errors were found in event log.

I attached the error in the code during creating a new topic.

 Fehler im Code.PNG You have insufficient rights to see the content.

KatjaAusFrankfurt
3 years ago
I have an idea, why no index files are created in App_Data\search_index folder. I debugged the re-index funktionality and found out:

- After installation of the forum I have no messages added to the baord. I have only one baord and it is empty

- During re-indexing YAF Forum try to update search index for each message. So if messageList is empty, nothing is done.

I suppose it is a "deadlock" problem: I can't create messages for the board beacause no index exists and I can't update or create index because no messages exists...

But I'm not expirienced with lucene, so it is just my assumption.

 MessageList_is_empty.PNG You have insufficient rights to see the content.

KatjaAusFrankfurt
3 years ago
I found the problem! By the creation of the first message in the empty board I ignored errors during debuggin (because of empty index) and could create the first message. After that I clicked re-index button in host settings and after that some files were created in the App_Data\search_index folder. See screenshot below.

And then I coud find the new message with the search funktionality.

After that the creation of further messages in the board work without errors.

BUT! The problem at the moment is: I couldn't finde the second message with the search. I tried to re-index database again and only after that I could find the second message with the search. So every time one user creates a new message the admin should click the re-index-button manually???

 Index files.PNG You have insufficient rights to see the content.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 Answer YAF Version: 3.0.3
3 years ago
Version 2.30.01 is online. The problem with the search doesn't work when is not initialized is fixed. Also when you try to create a new topic and the search is empty

https://github.com/YAFNET/YAFNET/releases