YAFLogo

filtergraph
  • filtergraph
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
5 years ago
I have installed YAF on a server with iis 7. The installation went okay but I cannot click any any links without getting a 404 error. At first I thought I had no access to the pages directory but I ruled that out by adding an html page and calling it with ~/pages/test.html. I have to insert the pages directory in the url or I get a 404 error. I cannot insert the pages directory into the url for other pages withouth getting a 404 error. So my thoughts are that there is a configuration missing or something configured incorrectly.

Does anyone know why this is happening?

Thanks in advance.

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
5 years ago
Do you mean the links inside the forum didn't work, or other urls from your site?

The problem is that all urls are handled via the urlrewriter. in your case you need to open the urlrewriter.config and change the line...

  <if url="^((?!\.ashx|\.asmx|\.axd|\.gif|\.png|\.jpg|\.ico|\.pdf|\.css|\.js|\/install|error\.aspx|auth\.aspx|default\.aspx|popup\.aspx|advanced\.aspx|digest\.aspx|ftb.imagegallery\.aspx|ckfinder).)*$">

to...

  <if url="^((?!\.ashx|\.asmx|\.axd|\.gif|\.png|\.jpg|\.ico|\.pdf|\.css|\.js|\/install|error\.aspx|auth\.aspx|default\.aspx|popup\.aspx|advanced\.aspx|digest\.aspx|ftb.imagegallery\.aspx|ckfinder|\/pages).)*$">

filtergraph
  • filtergraph
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
5 years ago
YAF is the website. I have not added it to another site.

It may have something to do with the server I was using (What, I do not know). I moved the YAF site to a different server and all is working.

Hyabusact
5 years ago
I am getting the same error but I cant move this to another site. When you click onto the forum it errors, when you click to log in, it errors and if you try to register it will error. All 404 errors. Any help?

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
5 years ago
Does it work when you disable url rewriting

<add key="YAF.EnableURLRewriting" value="false" />
Hyabusact
5 years ago
To the Web.config file?
Hyabusact
5 years ago
When I add that to the Web.config file, the site will not run.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
5 years ago
Sorry I forgot to mention you need to add it to the app.config