YAFLogo

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 Topic Starter YAF Version: 3.0.3
4 years ago
Another Maintenance Release

YAF.NET:

https://github.com/YAFNET/YAFNET/releases/tag/v2.2.4.20 

YAF.NET DNN Module:

https://github.com/YAFNET/YAFNET-DNN/releases/tag/v2.2.4.20-5828 

YAF.NET Sample Web Application:

https://github.com/YAFNET/YAF.SampleWebApplication/releases/tag/v2.2.4.15 

This is the first release which is compiled against .NET Framework 4.5.2.

New Features

  • [NEW] Impoved spam detection now you can define how many urls are allowed inside a message before flagged a spam

  • [NEW] Sitemap Provider for DNN Platform

  • [NEW] Redirect Forum Remote URL to new Window

  • [NEW #353] Added Spam Check when sending PM's

  • [NEW #341] IP lookup also in the banned IP section

  • [NEW] Added Import Function for the ActiveForums Module

changes

  • [FIXED #329] check box to enable topic watching and receive notification in quick reply form

  • [FIXED] Unable to Cast to object error during install.

  • [FIXED] when converting from html to bbcode preserve paragraphs

  • [FIXED] unable to cast object issue

  • [FIXED #334] Error on Ban User Page when there is no IP Address

  • [FIXED] user style cache was not cleared after changing Rank/Group

  • [FIXED] added a check if email address is provided when connect via Facebook

  • [FIXED #338] user was not deleted when have attachments

  • [FIXED #337] similar topics shows topics with no posts

  • [FIXED #342] url encode values when rewriting querystring

  • [FIXED] admins are not listed as mods and don't receive mod emails

  • [FIXED] board_poststats SP which do not delete readtracking before trying to delete removed topics

  • Added Canonical Meta Tag Module

  • [FIXED] issue with url search when use the word install or error

  • [FIXED] little issue with the finish language

  • [FIXED] updated SSO Facebook API to version 2.9

  • [FIXED] Issue with IP v6 Addresses

  • [FIXED #357] Quoting when user name contains html code

YAF.NET Community Appreciation Station

Super thanks to Jaben!!! Special thanks to JP, Zero2Cool! And also thanks to all users who report issues & bugs or suggest/request new features

Fork us on GitHub!

YAF.NET is on GitHub! https://github.com/YAFNET 

Follow us on Twitter and Facebook

YAF.NET Twitter is here: http://twitter.com/yafnet  and Facebook is here: http://www.facebook.com/pages/Yet-Another-ForumNET-YAF/156302224384947 

Build It!

Building YAF.NET from source requires Visual Studio 2017. YAF.NET can be build using the freely available Visual Studio Community 2017 .

Sponsor
johnk
  • johnk
  • 74.8% (Friendly)
  • YAF All-the-Time
4 years ago
Hi Ingo, just below your profile picture, it says you only have 2 posts. Is that a bug in the YAF code?
tester2000
4 years ago
Any chance to get it compiled against new framework versions?

Subject and description are not editable.

Is it related to number of posts?

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 Topic Starter YAF Version: 3.0.3
4 years ago
Quote:

Any chance to get it compiled against new framework versions?

No at this point 4.5.2 is the most common version. what would be the benefit of using newer versions? If you need different framework then you need to compile the source

https://github.com/YAFNET/YAFNET/releases/download/v2.2.4.1/YAF-v2.2.4.1-Source.zip 

Originally Posted by: tester2000 

Subject and description are not editable.

Is it related to number of posts?

When you edit the first message in a topic you can edit the description and title.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 Topic Starter YAF Version: 3.0.3
4 years ago
Originally Posted by: johnk 

Hi Ingo, just below your profile picture, it says you only have 2 posts. Is that a bug in the YAF code?

No its not a bug its a user error. I accidentally deleted my account. Posts count is fixed now

tester2000
4 years ago
Originally Posted by: tha_watcha 

Quote:

Any chance to get it compiled against new framework versions?

No at this point 4.5.2 is the most common version. what would be the benefit of using newer versions? If you need different framework then you need to compile the source

https://github.com/YAFNET/YAFNET/releases/download/v2.2.4.1/YAF-v2.2.4.1-Source.zip 

The benefit is that there are difficulties with compiling yaf with newer framework versions all the 3rd-party soft in mind.

Jaben almost didn't use it by the reason.

I have 4.7 installed on a dedicated server and I'm forced to compile the rest of asp.net code around forum in 4.5.2.

I wouldn't touch it but the owner was forced to switch server and has some current troubles.

JP
  • JP
  • 100% (Exalted)
  • YAF Leader
4 years ago
Tried to update using the 2.2.4.1 upgrade package, but it reverted the installed 2.2.3 beta to 2.2.2 beta when I ran the /install... 😕
He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 Topic Starter YAF Version: 3.0.3
4 years ago
Originally Posted by: JP 

Tried to update using the 2.2.4.1 upgrade package, but it reverted the installed 2.2.3 beta to 2.2.2 beta when I ran the /install... 😕

Where it tells 2.2.2? in the install wizard or in the footer?

JP
  • JP
  • 100% (Exalted)
  • YAF Leader
4 years ago
Originally Posted by: tha_watcha 

Originally Posted by: JP 

Tried to update using the 2.2.4.1 upgrade package, but it reverted the installed 2.2.3 beta to 2.2.2 beta when I ran the /install... 😕

Where it tells 2.2.2? in the install wizard or in the footer?

Everywhere...

In the upgrade wizard, in admin version check & the footer...

http://yetanotherforum.net/download 


He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 Topic Starter YAF Version: 3.0.3
4 years ago
Originally Posted by: JP 

Originally Posted by: tha_watcha 

Originally Posted by: JP 

Tried to update using the 2.2.4.1 upgrade package, but it reverted the installed 2.2.3 beta to 2.2.2 beta when I ran the /install... 😕

Where it tells 2.2.2? in the install wizard or in the footer?

Everywhere...

In the upgrade wizard, in admin version check & the footer...

http://yetanotherforum.net/download 

I only can guess that you somehow downloaded the wrong version.

https://github.com/YAFNET/YAFNET/releases/download/v2.2.4.1/YAF-v2.2.4.1-Upgrade.zip 

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 Topic Starter YAF Version: 3.0.3
JP
  • JP
  • 100% (Exalted)
  • YAF Leader
4 years ago
Originally Posted by: tha_watcha 

I only can guess that you somehow downloaded the wrong version.

https://github.com/YAFNET/YAFNET/releases/download/v2.2.4.1/YAF-v2.2.4.1-Upgrade.zip 

Sorry, that's the one I use... 😞

I download, copy the files to the installation and try to run /forum/install as I have done earlier too...

And it shows me: Upgrade Version: YAF.NET v2.2.2 BETA 20150525 (58)


He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]
guest
4 years ago
Hi,

Table in hostsettings and User on Admin don't active.

Please watch the video:

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 Topic Starter YAF Version: 3.0.3
4 years ago
Originally Posted by: tuanmta 

Hi,

Table in hostsettings and User on Admin don't active.

Please watch the video:

I updated the download packages i downgraded jquery to version 2.2.4

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 Topic Starter YAF Version: 3.0.3
4 years ago
Originally Posted by: JP 

Originally Posted by: tha_watcha 

I only can guess that you somehow downloaded the wrong version.

https://github.com/YAFNET/YAFNET/releases/download/v2.2.4.1/YAF-v2.2.4.1-Upgrade.zip 

Sorry, that's the one I use... 😞

I download, copy the files to the installation and try to run /forum/install as I have done earlier too...

And it shows me: Upgrade Version: YAF.NET v2.2.2 BETA 20150525 (58)

I dont know what went wrong but i just use the same download package for the test forum

http://testforum.yetanotherforum.net/ 

Did you try to download again?