YAFLogo

epinanab
  • epinanab
  • 56% (Neutral)
  • YAF Camper Topic Starter
2015-05-23T23:00:03Z
Hello Support,

My forum was running ok, but one day I get this error:

Quote:

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:

An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Source File: D:\inetpub\webs\aprendeandroidcom\yaf\web.config Line: 19

Show Additional Configuration Errors:

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (D:\inetpub\webs\aprendeandroidcom\yaf\web.config line 71)

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (D:\inetpub\webs\aprendeandroidcom\yaf\web.config line 77)

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (D:\inetpub\webs\aprendeandroidcom\yaf\web.config line 83)

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34248

I try to install the new version of YAF, but get the same error.... my congig file in line 19 is:

Quote:

<authentication mode="Forms">

<forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>

</authentication>

Sponsor
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.0 RC 3
2015-05-24T04:44:02Z
The error message already provides the problem and the solution

Quote:

This error can be caused by a virtual directory not being configured as an application in IIS.

You need to convert the folder as application in your IIS server.

If you run your own server you need to do this from within the IIS Manager

https://msdn.microsoft.com/en-us/library/bb763173(v=vs.140).aspx 

Or if you are using an hosted web from within your hosting panel.


UserPostedImage
epinanab
  • epinanab
  • 56% (Neutral)
  • YAF Camper Topic Starter
2015-05-24T20:00:07Z
Thanks! but.... how can I do this? I have a hosted web (aruba) and can't see any option in my administration panel, only can give permit in folder and IIS option are for the version of Framework that can i use (version 2 or version 4)

My forum was working for 2 year.... I can't understand why I stopped working (I don't touch anything)

Thanks in advance!! 🙂

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.0 RC 3
2015-05-26T07:59:06Z
Originally Posted by: epinanab 

Thanks! but.... how can I do this? I have a hosted web (aruba) and can't see any option in my administration panel, only can give permit in folder and IIS option are for the version of Framework that can i use (version 2 or version 4)

My forum was working for 2 year.... I can't understand why I stopped working (I don't touch anything)

Thanks in advance!! :)

So in that case, i would suggest contacting your host provider.


UserPostedImage
epinanab
  • epinanab
  • 56% (Neutral)
  • YAF Camper Topic Starter
2015-06-11T22:17:37Z
Thanks!! my provider enable aplication folder and now works ok!! thanks a lot for your support!! 🙂