YAFLogo

DarkLogix
  • DarkLogix
  • 63.2% (Friendly)
  • YAF Camper Topic Starter
7 years ago
My web server is a 2008R2 VM and I'm trying to use a remote SQL 2014 server
lets say the names of them are 2008R2-WEB and 2008R2-SQL (since the OS is windows server 2008R2)

I created a DB in the SQL instance named YAFNET and made an AD used named YAFNET then created a SQL login for that AD user and granted it DB owner permission to the YAFNET DB.

I then extracted the contents of the zip file to D:\web\Forum\
and made a virtual directory off the default site and named the virtual directory forum.
then I copied and renamed the copy of recommended.web.config to web.config

but on browsing to https://2008r2-web/forum/install/default.aspx I get runtime error
Description: An exception occurred while processing your request. Additionally, another exception occurred while executing the custom error page for the first exception. The request has been terminated

can some one help?
Sponsor

DarkLogix
  • DarkLogix
  • 63.2% (Friendly)
  • YAF Camper Topic Starter
7 years ago
Well I've messed with it some more and when I made a site on port 444 it worked but making it a virtual directory of my main doesn't.

https://github.com/YAFNET/YAFNET/wiki/Installation 
and edited the line is app.config and copied the /bin folder but it still doesn't work

I think I got it worked out.
I made a new site using 444 then I exported that via IIS, and then imported it using IIS as an app then I set it to use a different app pool and now its not using the computer account to access sql (IE I didn't want it to use the computer account)

its a bit sluggish but it might be due to the web server's storage being slow (the SQL is using a datastore that's on SSD's)
DarkLogix
  • DarkLogix
  • 63.2% (Friendly)
  • YAF Camper Topic Starter
7 years ago
Well I thought it was working but just tried to create a 2nd user (IE a non-admin) and got the following
reCAPTCHA needs to be configured with a site & secret key.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
7 years ago
Originally Posted by: DarkLogix 

Well I thought it was working but just tried to create a 2nd user (IE a non-admin) and got the following
reCAPTCHA needs to be configured with a site & secret key.



Sorry but this is a known bug at the moment, even if you don't use reCaptcha simply add an site & secret key in the host settings (it doesn't matter what you enter actually). This issue will be fixed in 2.2.1.
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button