YAFLogo

cguerrero
  • cguerrero
  • 53% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Hi,

I upgraded to version 1.9.6 from 1.9.4. I detected that the Moderate button is always displayed even Guest members.

The other two Admin buttons(Admin,Host), are hidden properly. The confituration Roles and Ranks are the same as before...

Any idea?

Thanks,

cguerrero

Sponsor

squirrel
9 years ago
Somewhere in your access mask or forum/category configuration, the access masks or roles are not quite right.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
cguerrero
  • cguerrero
  • 53% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Thank you squirrel...but I checked my settings. I'm not seeing anything strange.

I think the Guest configuration is ok...

This is my configuration:

ACCESS MASKS

Admin Access Mask

Read Yes | Post Yes | Reply Yes | Priority Yes |

Poll Yes | Vote Yes | Moderate Yes | Edit Yes |

Delete Yes | Upload Yes | Download No

Moderator Access Mask

Read Yes | Post Yes | Reply Yes | Priority No |

Poll No | Vote Yes | Moderate Yes | Edit Yes |

Delete Yes | Upload No | Download No

Member Access Mask

Read Yes | Post Yes | Reply Yes | Priority No |

Poll No | Vote No | Moderate No | Edit Yes |

Delete No | Upload No | Download No

Read Only Access Mask

Read Yes | Post No | Reply No | Priority No |

Poll No | Vote No | Moderate No | Edit No |

Delete No | Upload No | Download No

No access

Read No | Post No | Reply No | Priority No |

Poll No | Vote No | Moderate No | Edit No |

Delete No | Upload No | Download No

ROLES

Administration (Linked)

Priority: 0 | Is Guest No | Is Start No | Is Moderator No | Is Admin Yes | PMs 8 |

User Albums Number: 0 | Album Images Number: 0 |

Style: No

Max number of chars in a user signature: 128 | User signature BBCodes: No | User signature HTML tags: No |

Guest (Unlinkable)

Priority: 0 | Is Guest Yes | Is Start No | Is Moderator No | Is Admin No | PMs 30 |

User Albums Number: 0 | Album Images Number: 0 |

Style: No

Max number of chars in a user signature: 0 | User signature BBCodes: No | User signature HTML tags: No |

Member (Linked)

Priority: 0 | Is Guest No | Is Start Yes | Is Moderator No | Is Admin No | PMs 100 |

User Albums Number: 0 | Album Images Number: 0 |

Style: No

Max number of chars in a user signature: 128 | User signature BBCodes: No | User signature HTML tags: No |

RANKS

Administration

Priority: 0 | Is Start No | Is Ladder No | PM limit 0 |

User Albums Number: 0 | Album Images Number: 0 |

Style: No

Max number of chars in a user signature: 128 | User signature BBCodes: No | User signature HTML tags: No |

Advanced Member

Priority: 0 | Is Start No | Is Ladder Yes (30 posts) | PM limit 0 |

User Albums Number: 0 | Album Images Number: 0 |

Style: No

Max number of chars in a user signature: 128 | User signature BBCodes: No | User signature HTML tags: No |

Guest

Priority: 0 | Is Start No | Is Ladder No | PM limit 0 |

User Albums Number: 0 | Album Images Number: 0 |

Style: No

Max number of chars in a user signature: 0 | User signature BBCodes: No | User signature HTML tags: No |

Member

Priority: 0 | Is Start No | Is Ladder Yes (10 posts) | PM limit 0 |

User Albums Number: 0 | Album Images Number: 0 |

Style: No

Max number of chars in a user signature: 128 | User signature BBCodes: No | User signature HTML tags: No |

Newbie

Priority: 0 | Is Start Yes | Is Ladder Yes (0 posts) | PM limit 8 |

User Albums Number: 0 | Album Images Number: 0 |

Style: No

Max number of chars in a user signature: 128 | User signature BBCodes: No | User signature HTML tags: No |

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
9 years ago
The masks and roles look ok, but you also need to check each forums settings which Mask is applied to each Role.
cguerrero
  • cguerrero
  • 53% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
But in:

SETTINGS> FORUMS

for each forum I have:

Group | Access Mask

Administration | Admin Access Mask

Guest | Read Only Access Mask

Member | Member Access Mask

I think it's all ok...

Is there any other setting to check the roles?

I really appreciate any help you can provide,

cguerrero

cguerrero
  • cguerrero
  • 53% (Neutral)
  • YAF Forumling Topic Starter
8 years ago
Trying to solve the problem. I have migrated from the Verson 1.9.4 to 2.0.0. And the problem is still there...

In version 1.9.4, the moderator button does not show as a Guest, but in 2.0.0...the button is displayed...

The configuration is the same, I only executed de migration proces...

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
8 years ago
There is only one thing left you need to check, maybe the guest account is assigned to the wrong roles.

  1. Go To Admin -> Users & Roles -> Users

  2. Search for "Guest" User click on the edit button to open the edit page.

  3. On the "User Roles" check which Roles are enabled, only the Guest Role should be enabled

cguerrero
  • cguerrero
  • 53% (Neutral)
  • YAF Forumling Topic Starter
8 years ago
everything is correct :(

Only, if I remove the check moderate from the Admin Access Mask, the moderate button disappears...but in this case, the administrator can't moderate the forum...

I don't understand...