YAFLogo

PM2312
  • PM2312
  • 52% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
I've done a install of the yaf forum on an existing umbraco site, but not using integrated membership.

I can get the forum loaded up at: http://localhost/forum/ and it displays ok.

If I navigate to any link I get a "The resource cannot be found error", ie on
http://localhost/forum/yaf_rules.aspx
http://localhost/forum/yaf_login.aspx?returnurl=%2fforum%2f

Have I missed something in the setup? what shall I check for?

Thanks
Pete

Sponsor

bbobb
  • bbobb
  • 100% (Exalted)
  • YAF Developer
9 years ago
Does it work without url rewriting?
PM2312
  • PM2312
  • 52% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
No it didn't, I've now tried changing the setup so the forum is based in the /forum folder, and active as an application.

I now get this error:
The type or namespace name 'YAF' could not be found

on Line 101:

Of the web.config.

Any ideas? All the dll's are in the bin folder.

I have the forum root and file root set as "~/forum"

Thanks
squirrel
9 years ago
To do a non-integrated install:
1. On your host, create a /forum folder off the application root.
2. Inside IIS configuration:
--> Create a New Application Pool - name it something unique for the forum. Make sure it is set to use ASP.NET v4 and Integrated Pipeline.
--> Right click the folder you created (/forum) and choose "Convert to Application". - be sure to select the application pool you just created.
3. Open FTP, go to /forum folder and clear it out completely.
4. Download the YAF archive from GitHub and unpack it into a folder on your local machine.
5. Make necessary changes to db.config and mail.config for working with your database and mail server.
6. Copy the default web.config file from the "./webconfigs" folder to the root of the forum folder you have (make sure to name it web.config).
4. Upload the contents of the forum package to the /forum folder. When done, that /forum folder will have it's own ./bin folder along with the rest of the YAF filetree.
http://domainname.ext/forum/install  and process the installer, verifying mail and DB setup.


Notes:
In order for the server to 'remember users' logged into a YAF forum, you must uncomment and put in a set of unique machineKeys (search forums on how to get a set generated and so on).
YAF is a fairly intensive ASP.NET application. To avoid slow 'restarts' of the YAF software from IIS idling down the Application Pool, open IIS, modify application pool that YAF runs in to NOT idle timeout the site, and to perform a 'scheduled app pool recycle' anywhere from once a day to once a week... This will tell IIS to keep YAF in memory - this will reduce 'load times' if the forum application has been closed.

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
PM2312
  • PM2312
  • 52% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Thanks for the great install instructions.

I now get a server error 500 on the web.config setup.

I believe the forum application web.config is trying to inherit the parent web.config settings and all settings therein related to Umbraco.

I modified the forum web.config upto the stage where it now gives the error in IIS:
"The configuration section 'appSettings' cannot be read because it is missing a section declaration"

Do you need to see the whole contents of each web.config?

Thanks



squirrel
9 years ago
If you configured the /forum folder as an Application in IIS, then the two configs will stay seperate. Being an application is supposed to block inherited configs.

Lets try this - make sure that your web.config in your root folder is clear of ANY YAF lines in it - and then re-copy over the default web.config from YAF's web.configs folder to the /forum folder.

Open the YAF config, look for a line that shows customErrors="RemoteOnly" and change it to customErrors="Off" - then open IIS and go to site that is hosting YAF and select it in the left. On the right, look for "Errors" and open it - Edit the Feature Settings (right corner) to "show detailed errors" and no "Custom Error Pages" -- this will turn off the default "500 Error" page off and let us see the 'detailed descriptions' of the error in IIS.

If setting those options does not get us past a 500 server error, then the next step to verify is to rename the web.config in your 'root' folder to like web.config.off or something like that - to disable it temporarily -- then retry to load YAF folder. If it works, then we have to find the setting so that IIS does not try to inherit configs.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
PM2312
  • PM2312
  • 52% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Thanks for the great help.

Ok, when I disable the root web.config, the forum boots up but goes to http://localhost/forum/forum/install/ which I guess is just a setting in the app.config to get it to go to the right folder.

If I turn the root web.config back on it then starts throwing the errors like:
Could not load file or assembly 'UrlRewritingNet.UrlRewriter' or one of its dependencies. The system cannot find the file specified

So I guess it's trying again to inherit the roots web.config settings.

Like you say we need the setting so that IIS does not try to inherit configs.

I tried wrapping the system.web in a location tag, on the root and child web.configs, but it seemed to ignore it, perhaps I'm not doing it correctly.

Thanks

squirrel
9 years ago
Is your forum application in it's own "Virtual Application" in IIS?
Also, that path issue (with the /forum/forum) - check the app.config and verify the paths inside there - one might have an extra /forum on it. Usually in this configuration, the forum path of ~/ is suffecient - that maps things properly in ASP.NET --

I'll look for that information to block IIS from inheriting web.configs, but I believe it's tied to the virtual application status in IIS.

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
squirrel
9 years ago
Ok - scratch my last post.

There is an issue with inheritance in IIS and web.configs.

I will have a post for you with a modification to your 'root' application's web.config -- that will block the inheritance for the child applications -- this should cure the YAF issue.

There is another way to do it with modifications to the YAF config - I'm checking which one is the 'better route' to take (in regards to further updates to yaf being simple for you. Thanks for your patience!

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
PM2312
  • PM2312
  • 52% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Ok thanks.

If there's no fix available, the only other option I was thinking was to take the umbraco web.config from the root, and manually change all the sections to suit the yaf web.config - if this was possible, using etc.

Thanks
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button