johnk
  •  johnk
  • 74.2% (Friendly)
  • YAF All-the-Time Topic Starter
2013-08-13T02:47:36Z
From /forum/default.aspx?g=admin_digest

I clicked on "Send Test" digest button. I got the digest by email. However at the end of the email I saw these characters. Does this mean the aliens have taken over YAF?

�㰀椀洀最 猀爀挀㴀∀嬀洀瀀琀愀最 ⸀㈀㜀㌀㈀㄀㐀㐀㈀㤀㌀㤀㄀㄀㤀㘀洀瀀琀愀最崀∀ 愀氀琀㴀∀∀ 眀椀搀琀栀㴀∀㄀∀ 栀攀椀最栀琀㴀∀㄀∀ 戀漀爀搀攀爀㴀∀ ∀ 猀琀礀氀攀㴀∀栀攀椀最栀琀㨀㄀瀀砀 ℀椀洀瀀漀爀琀愀渀琀㬀眀椀搀琀栀㨀㄀瀀砀 ℀椀洀瀀漀爀琀愀渀琀㬀戀漀爀搀攀爀ⴀ眀椀搀琀栀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀洀愀爀最椀渀ⴀ琀漀瀀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀洀愀爀最椀渀ⴀ戀漀琀琀漀洀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀洀愀爀最椀渀ⴀ爀椀最栀琀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀洀愀爀最椀渀ⴀ氀攀昀琀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀瀀愀搀搀椀渀最ⴀ琀漀瀀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀瀀愀搀搀椀渀最ⴀ戀漀琀琀漀洀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀瀀愀搀搀椀渀最ⴀ爀椀最栀琀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀瀀愀搀搀椀渀最ⴀ氀攀昀琀㨀  ℀椀洀瀀漀爀琀愀渀琀㬀∀⼀㸀਀
Sponsor
Zero2Cool
2013-08-13T10:11:08Z
Simple answer, yes. You heard nothing. You see nothing. You know nothing.
squirrel
2013-08-14T03:38:09Z
johnk - Look into your YAF configuration - somewhere in there is a 'default' language/culture setting for a forum. That can set all registrations to a 'default' culture. I ran into a situation where older forums defaulted the 'language' to "china.xml" in the user tables, even though the browser properly identified the visual language the site displayed to english, the forum stored "china.xml" in the user record - and when mails and digests were sent, they were sent using the 'culture' in the user record, with the 'forum default' as a fallback if I remember correctly...

Not sure if this helps you or not. Maybe check your profile and see if there is a 'default' language set on your account and try a test digest or something --

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
johnk
  •  johnk
  • 74.2% (Friendly)
  • YAF All-the-Time Topic Starter
2013-08-14T04:40:54Z
In default.aspx?g=admin_boardsettings

I saw the default language is set as English (US). There is no option called "default" in drop down menu.

PS: I did try the test digest - per the steps above. That is how I noticed the weird characters. Maybe its a secret message 🙂
johnk
  •  johnk
  • 74.2% (Friendly)
  • YAF All-the-Time Topic Starter
2013-08-14T04:43:10Z
Originally Posted by: Zero2Cool 

Simple answer, yes. You heard nothing. You see nothing. You know nothing.



You seem to know about the alien protocols. How tight is your tinfoil hat? :-d
squirrel
2013-08-14T05:23:10Z
There's a few screws loose, I'm sure - lol

I've gotten the same cryptic messages from one of the YAF forums I admin - just every once in a while. Have seen a couple other reports about it as well in the past. Only reason I mention the language files is when I had a problem updating an old 1.9.1.8 board, it was all 'north american' users, and almost 90% in the db had one field set to value of china.xml in one of the user table fields - I never thought much of it - and haven't looked at a newer db to see if that behavior even exists anymore, etc... More of just a random thought --
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
johnk
  •  johnk
  • 74.2% (Friendly)
  • YAF All-the-Time Topic Starter
2013-08-18T21:38:59Z
I just checked the DB. The default value for language is now NULL for most users.
squirrel
2013-08-18T22:03:45Z
Were there any records that had any entry at all in that table? Just curious --

I just scanned one of my dbs and found probably about 200 users who had a language 'set' in that field. The rest of my some 2000 users had no entry. I will do some counting SQL next time I'm logged into that server and see what it comes up with --

I don't know if any of this relates to the digest language - but more relates to any 'notification' message sent. My real question (and I'll know the answer with some testing at some point) if this is what causes strange message output...

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
johnk
  •  johnk
  • 74.2% (Friendly)
  • YAF All-the-Time Topic Starter
2013-08-18T23:43:21Z
Yes, about 5% of people who manually updated their profile and clicked save button had entry set as "english.xml" in the table.
squirrel
2013-08-19T01:20:47Z
Ok -- I'm wondering if this chain of events is possible (won't know without chasing source code):

1: Digest send 'ordered'
2: user profile checked for "language culture" - if not found then
3: board settings checked for "default language culture" -- if not found then:
4: ?? random or first inline language selected from filetree maybe?

What YAF does when it can't find a language selected in either place is the real question -- if it defaults, what does it default to --?

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
johnk
  •  johnk
  • 74.2% (Friendly)
  • YAF All-the-Time Topic Starter
2013-08-19T01:36:37Z
I am guessing it should default to forum default (which is currently set at English (US)). Option 3 above always have a default value. It cannot be null (since it is a dropdown). Exception could be if there was an error during upgrade.
tha_watcha
2013-08-19T02:38:12Z
Originally Posted by: squirrel 

Ok -- I'm wondering if this chain of events is possible (won't know without chasing source code):

1: Digest send 'ordered'
2: user profile checked for "language culture" - if not found then
3: board settings checked for "default language culture" -- if not found then:
4: ?? random or first inline language selected from filetree maybe?

What YAF does when it can't find a language selected in either place is the real question -- if it defaults, what does it default to --?



I don't think this can happen the board settings always exist because the default values are hard coded, and if i remember correctly the default fallback language when loading the language resources is also hardcoded to English.xml.


UserPostedImage
squirrel
2013-08-19T03:55:43Z
That was my big question - is that was there a fallback mechanism and what it would default to. I think I'll get into my two sites DBs that I have and see if I see anything amiss - will report back as needed --

Thanks tha_watcha for looking into that for us!
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved