YAFLogo

AlexW
  • AlexW
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Has anyone managed to do a step by step guide on integrating with the default ASP.Net membership system yet? I've seen threads that have started this so far. I am looking for a fourm that will authenticate when users are logged onto my site and I'm not certain that YAF can do this without a lot of messing about?
Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
9 years ago
Originally Posted by: AlexW 

Has anyone managed to do a step by step guide on integrating with the default ASP.Net membership system yet? I've seen threads that have started this so far. I am looking for a fourm that will authenticate when users are logged onto my site and I'm not certain that YAF can do this without a lot of messing about?

Did you read the documentation and tried out the ASP.NET Sample Application?

https://yafnet.codeplex.com/wikipage?title=YAF.NET%20Integration%20in%20to%20an%20existing%20ASP.NET%20Application&referringTitle=Documentation 

Zero2Cool
9 years ago
I am a user of the sample application. It is bitchin'ly awesome!

I am also in the court that YAF should create a little CMS wrapper for it so we can have a better replacement for DNN use.

AlexW
  • AlexW
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
I followed the instructions to integrate with my existing site but I'm getting the following error:

The type or namespace name 'Properties' does not exist in the namespace 'YAF' (are you missing an assembly reference?)

The issue is at forum/Web References/RegisterV2/Reference.cs

public RegisterV2() {

this.Url = global::YAF.Properties.Settings.Default.YAF_RegisterV2_RegisterV2;

AlexW
  • AlexW
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Is anyone able to help? I have tried these instructions again and I get the following on ..forum/install/Forum.aspx.designer.cs:

The type or namespace name 'Forum' does not exist in the namespace 'YAF' (are you missing an assembly reference?)

Code: protected global::YAF.Forum forum;