YAFLogo

metta123
  • metta123
  • 50.2% (Neutral)
  • YAF Camper Topic Starter
9 years ago
I am trying to sort out the login/register if you have a facebook account feature. I have just changed some of the .cs files and rebuilt the .dll files. I think it was Utils/Helpers/ValidationHelper.cs, as well as 2 other corresponding files. This was to resolve a string declaration issues as advised by YAF developer in another post. This has all been done and I believe resolved.

The new problem is as follows ...

I've followed the steps and built/linked facebook app to my forum. The login with facebook button appears on my login page. I have successfully registered and logged in my own facebook account. I can always use, and it works everytime without fail. This is also the same facebook account I used to set up the app in the first place.

If I get another facebook account that has an account in my forum. They then login with facebook and it doesn't work. If I get a new account for my forum that has an existing facebook account. They then try and it fails also.

It's all live and can be found at aloadofball.com/Login.aspx. So anyone with a facebook account could try it out. Then would see the problem in action.

Generally what happens is I click the login with facebook. Put in the credentials and then the screen just vanaishes and Im in the same situation as when I started.

Any light on this would be greatly appreciated.

Thank You

metta123

aloadofball.com

Sponsor

metta123
  • metta123
  • 50.2% (Neutral)
  • YAF Camper Topic Starter
9 years ago
Right. I'm still having difficulty with integrating facebook login facility into my application. I thought I would try and resolve it with Twitter aswell What a nightmare that was.

http://www.aloadofball.com .

Neither of them work. In fact does this integration facility actually work for yaf.net at all. As it is key to increase user base. Does anyone have a link to where the facebook/twitter integration works so I can login and get more of an idea of what is being achieved.

Thank

metta123

aloadofball.com

Zero2Cool
9 years ago
1.9.6 I had it working, but the Twitter API changed so I removed them both when I moved to beta 2.0.

There was a thread/topic here that helped. I just don't know which one off hand and don't have a moment to search for it. Hope you get it figured out.

metta123
  • metta123
  • 50.2% (Neutral)
  • YAF Camper Topic Starter
9 years ago
Hi,

Anyone know of any sites with a YAF forum where the Login with twitter feature currently works? As of today. They have made some recent minor changes at Twitter dev.

Thanks,

metta123

aloadofball.com

metta123
  • metta123
  • 50.2% (Neutral)
  • YAF Camper Topic Starter
9 years ago
I have resolved the initial problem with Facebook. I had it in Sandbox mode. So for any of you out there once you have built the Facebook app please take off Sandbox mode and it will work universally. I put my hands up. Now on to the Twitter issues. This issue from its title is done.