YAFLogo

Gritty
  • Gritty
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
I am having a problem with the Security Image during user registration on a site that I have set up with YAF, and yet I have another site that does work fine.

My sites are hosted on GoDaddy and the site that works is the main root directory site, and the site that does not work is in a subdirectory.

Everything else seems to work fine. I have set up my admin user and can seem to do everything, but I am prevented from registering a new user, since the Security Image letters can not be verified, and I can not generate a new image.

Not really quite sure what to do to resolve this so any guidance would be greatly appreciated.

Sponsor

JP
  • JP
  • 100% (Exalted)
  • YAF Leader
9 years ago
Are you talking about the ReCaptcha add-on feature?
He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]
Gritty
  • Gritty
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Well, the link for 'Generate New Image' does contain a command for 'RefreshCaptcha' so I suppose so.

I believe this is just the default setup for the site since I don't recall selecting any unusual options during installation.

Gritty
  • Gritty
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
9 years ago
Originally Posted by: Gritty 

Well, the link for 'Generate New Image' does contain a command for 'RefreshCaptcha' so I suppose so.

I believe this is just the default setup for the site since I don't recall selecting any unusual options during installation.

Which Captcha did you use ReCaptcha or the Yaf Captcha (It can be set under Host -> Host Settings -> Features -> Captcha Settings -> Enable CAPTCHA/reCAPTCHA for Register). If you use ReCaptcha the "Generate New Image" Button is not visible.

Quote:

Everything else seems to work fine. I have set up my admin user and can seem to do everything, but I am prevented from registering a new user, since the Security Image letters can not be verified, and I can not generate a new image.

Is the Image not shown or is it shown but can not be validated?

Gritty
  • Gritty
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Not quite sure what has happened, but when I checked today the image refresh and verification actually worked!

Apparently not necessary now but just to answer your questions:

When I checked my settings, it is set up for YafCaptcha, and the "Generate New Image" button is definitely visible.

And the image is shown, it just could not be validated or generate a new one.

Thanks so much! I had given up hope on this but your response motivated me to check one more time and I was very glad to discover it worked.

Thank you.

JP
  • JP
  • 100% (Exalted)
  • YAF Leader
9 years ago
A bit off-topic - but is there an easy way for calling the YafCaptcha verification from another web application so I don't have to write my own?
He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]