YAFLogo

acturbo
  • acturbo
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
i just spent 4 hours trying to get YAF to connect to SQL Express 2008 R2 on my virtualized web server. I get this error message:

Failed to connect:

Failed to generate a user instance of SQL Server due to failure in retrieving the user's local application data path. Please make sure the user has a local user profile on the computer. The connection will be closed.

Yes, i have found this same error in other posts on this forum, i've googled as well, but i still don't have a clear solution.

my setup:

- running Windows Server 2008 (all working good)

- my web site has been up and running (all good for months)

- .NET 4.0 set in the application pool

i did this:

- downloaded YAF, installed to /forum and moved files as directed (config to root)

- config files are in /mydomain

- updated app.config with my password

- updated web.config with my new machine key (generated by IIS)

- downloaded and installed SQL Server 2008 R2 Express

- created a new User "sqluser" (not admin, just user)

SQL Server Properties

- not using a "Built-in account" (unchecked)

- logged on as ".\sqluser"

next...

- i tried to run /mydomain/forum/install

i get the error posted above.

db.config

Also, i have 13 screenshots of my settings that could make it easier to see what's going on. I can provide this privately to anyone that can help.

- SQL settings

- User Account settings

- IIS settings .. connection string <--- this one may be good

If possible, please post the EXACT correct code to copy into this db.config file.

thanks for your help.

ac

Sponsor

acturbo
  • acturbo
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
minor update:

The database included with YAF 1.9.6.1 requires SQL 2008 R2 SP3.

If you use SQL 2008 R2 (or SP1, or SP2) it won't work.

FTR, I'm still not up and running yet.

squirrel
9 years ago
If you have SQLExpress installed on your server, then you should not be attaching a datafile at runtime. You need to modify your db.config as noted in the installation instructions, which will enable your webserver to communicate with your SQL server.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
squirrel
9 years ago
http://forum.yetanotherforum.net/yaf_postsm58486_DB-Connection-Failure.aspx#post58486 

For even more clarification, check the whole topic  which will explain the issue and the path to resolution. Search rocks!

EDIT: The connection string given in above topic is for an SQLExpress server on the same machine as the webserver. If it's at a different IP or dns name, you need to update the connection string as needed.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
acturbo
  • acturbo
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
9 years ago
Thanks. I ended up having my SQL expert review my installation and configuration. He figured out the SQL 2008 R2 SP3 issue so that we could read the newer .MDF format, then he updated the IIS7 settings to reflect our new "sqluser". Our forum seems to be working now.

The next issue is email. We use "POP before SMTP" mail security for legacy reasons, but that doesn't seem to be supported. I have to dig into this a bit more before posting questions.

Thanks again.

ac

PS ... and yes, i saw the Colleen posts before posting 🙂

squirrel
9 years ago
Originally Posted by: acturbo 

minor update:

The database included with YAF 1.9.6.1 requires SQL 2008 R2 SP3.

If you use SQL 2008 R2 (or SP1, or SP2) it won't work.

FTR, I'm still not up and running yet.

If you use the connection string that connects to the server itself, then run the install script, your database will be housed on the server, and is supported on SQL 2005/2008 full or express (express does not support Full Text Indexing)... I've never used the flatfile on an installation - always native client to the sql server and let the server instance house the db, not the webserver datastore.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend