YAFLogo

rte101
  • rte101
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
I have both twitter and facebook login set up with

-keys in the config file

-all clear from twitter/facebook developer sites

-both sign in options enabled in host settings

-buttons show up fine and ask for permission to share the account

When I authenticate either the twitter or facebook popup, both times I am greeted with either a messagebox (twitter) or one of those java dialogs on the page (fb):

"Single Sign On is deactivated for that User, you need to activate it in your Profile Settings to use that feature."

Now I'm not one to ignore error messages, but I cannot decipher what this one is trying to say. What am I doing wrong here?

Sponsor

Thantis
  • Thantis
  • 81.8% (Honored)
  • YAF Commander
10 years ago
I could be wrong, since I don't use either service myself, but I imagine each user needs to setup their profile with their username/id and set an option to use them. Check under My profile->edit profile. If this doesn't help, there are several threads about how to set this up properly, make sure to make use of the forum search to find them.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
rte101
  • rte101
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
Hrm. Well I think I understand what this is now. I was probably thrown off by a project I did a while ago that had a whole different approach to oauth.

Thanks for your time and quick responses.