YAFLogo

Bill Gaske
  • Bill Gaske
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
I just ran up an new instance of YAF 1.9.6.1 using a valid certificate and am running it over https.

In the Current Board Settings I have unchecked “Use Google Hosted CDN jQuery UI CSS File?” and have also changed the app.config setting for YAF.BaseUrlMask as below:



When navigating my YAF instance over https I am getting the warning “Do you want to view only the webpage content that was delivered securely” because there are rewquest from my browser that look like:

Http Request: GET /ajax/libs/jqueryui/1/jquery-ui.min.js

I do not want to work around this issue with browser settings.

How can I get the ajax GET request to be made over Https?

Are there any other areas of YAF that need to be changed because of similar issues?
Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
You can change that url in the app.config of yaf

<
add key="YAF.JQueryUIFile" value="https://ajax.googleapis.com/ajax/libs/jqueryui/1/jquery-ui.min.js" />

and also

<add key="YAF.JQueryUILangFile" value="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.16/i18n/jquery-ui-i18n.min.js" />
Bill Gaske
  • Bill Gaske
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
10 years ago
Thanks so much, this worked and is exactly what I needed.
ocortez
  • ocortez
  • 50.2% (Neutral)
  • YAF Forumling
10 years ago
Hi,

I too have the same issue with ssl. I changed the app.config and the forum settings but still get

http://ajax.googleapis.com/ajax/libs/jqueryui/1/jquery-ui.min.js 
yaf_admin_boardsettings.aspx


Any ideas?

Thanks,
Ozzy
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
Did you changed both app settings. I edited my post the code blocks where broken before and shown only one setting.
ocortez
  • ocortez
  • 50.2% (Neutral)
  • YAF Forumling
9 years ago
I don't follow....what do you mean both app settings? This is what my app.config looks like



























































































Thanks,
Ozzy
ocortez
  • ocortez
  • 50.2% (Neutral)
  • YAF Forumling
9 years ago
My mistake I just realized that the two lines were commented out. Sorry I'm totally new at this stuff. Many thanks for the response and help.

Best,
Ozzy Cortez
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button