f0zzyNUE
  •  f0zzyNUE
  • 100% (Exalted)
  • YAF Commander Topic Starter
2012-02-09T10:14:28Z
Hi,

when using the YAF mobile theme for mobile devices there is a slight glitch in the paging functionality. Whereas in the regular themes you find a pager on top of the list and on the bottom of the lists, in the YAF mobile theme there is only a pager on top.

The issue is that when you finish reading posts on one page you don't know wheher there are more posts without scrolling up and having a look at the top for the pager to switch to the next page.

Example: Post List View of a topic.

Moreover the "who reads the topic" info is missing in the mobile theme.

Would be great if there could be a fix for the mobile theme.

TIA
CHris
Sponsor
tha_watcha
2012-02-09T11:41:59Z
Originally Posted by: f0zzyNUE 

Hi,

when using the YAF mobile theme for mobile devices there is a slight glitch in the paging functionality. Whereas in the regular themes you find a pager on top of the list and on the bottom of the lists, in the YAF mobile theme there is only a pager on top.

The issue is that when you finish reading posts on one page you don't know wheher there are more posts without scrolling up and having a look at the top for the pager to switch to the next page.

Example: Post List View of a topic.



Agreed makes sense to have a bottom pager

You can grab the updated file from the repository if yo want http://yafnet.codeplex.c...set/changes/a048627e1cd5  .

Originally Posted by: f0zzyNUE 


Moreover the "who reads the topic" info is missing in the mobile theme.



This is not an usability problem, all the unnecessary stuff is is hidden but if you want the to show simple replace the code (In the same file)

<YAF:Pager ID="PagerBottom" runat="server" LinkedPager="Pager" UsePostBack="false" />
<asp:PlaceHolder ID="mobileHolder" runat="server" Visible="false">
<table class="content postForumUsers" width="100%">
    <YAF:ForumUsers ID="ForumUsers1" runat="server" />
</table>


to

<YAF:Pager ID="PagerBottom" runat="server" LinkedPager="Pager" UsePostBack="false" />
<table class="content postForumUsers" width="100%">
    <YAF:ForumUsers ID="ForumUsers1" runat="server" />
</table>
<asp:PlaceHolder ID="mobileHolder" runat="server" Visible="false">

<table cellpadding="0" cellspacing="0" class="command" width="100%">


UserPostedImage
f0zzyNUE
  •  f0zzyNUE
  • 100% (Exalted)
  • YAF Commander Topic Starter
2012-02-09T14:31:27Z
did you also change code behind? after updating posts.ascx I still don't see a pager in the footer in the mobile theme ... there is just the "quick reply box" and the footer with YAF-info being displayed.
tha_watcha
2012-02-09T14:38:59Z
Originally Posted by: f0zzyNUE 

did you also change code behind? after updating posts.ascx I still don't see a pager in the footer in the mobile theme ... there is just the "quick reply box" and the footer with YAF-info being displayed.



no it should be visible as soon as you save the file and refresh the Page in the Browser. You modified the File in the Folder ../Themes/YafMobile/MobilePages/ right?

UserPostedImage
f0zzyNUE
  •  f0zzyNUE
  • 100% (Exalted)
  • YAF Commander Topic Starter
2012-02-09T16:24:08Z
oops - nope ... updated the file in the pages folder below the root ...

now that i've put it in the right folder it works like a charm.

tausend dank!

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved