YAFLogo

kdikeman
  • kdikeman
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
11 years ago

I am on winhost using SQL 2008, IIS7 on YAF version 1.9.4.

I am having an error where the admin site will not work at all in IIS7 targeting .Net 4 for my project. If I set both IIS7 on 3.5 and code to 3.5 the admin site will come up but without the left hand nav menu. I've If I test local on IIS6 it works fine I get both the admin and left nav to work. Once I compile on 4 set the site to 4 and push out the code the admin site will not work at all on IIS7 but still works fine in IIS6.

The error I get is on the DNA_UI_JQuery side. All DNA files necessary are in the /bin directory.

Thoughts?

Request failed./nDNA.UI.JQuery/n at DNA.UI.JQuery.View.RenderBeginTag(HtmlTextWriter writer) at DNA.UI.JQuery.NavView.RenderBeginTag(HtmlTextWriter writer) at System.Web.UI.WebControls.WebControl.Render(HtmlTextWriter writer) at System.Web.UI.WebControls.CompositeControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) at System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) at System.Web.UI.Control.RenderControl(HtmlTextWriter writer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) at System.Web.UI.WebControls.WebControl.RenderContents(HtmlTextWriter writer) at System.Web.UI.WebControls.WebControl.Render(HtmlTextWriter writer) at System.Web.UI.WebControls.CompositeControl.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) at System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) at System.Web.UI.Control.RenderControl(HtmlTextWriter writer) at YAF.Controls.AdminMenu.Render(HtmlTextWriter writer) at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) at System.Web.UI.Control.RenderControl

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
11 years ago
The dna Controls didnt work in .NET4 with Medium Trust.

You can resolve this by..

- Switching to Full Trust (If possible)

- Downgrade to .NET 3.5

- Or best option Upgrade to latest YAF 1.9.5.5

kdikeman
  • kdikeman
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
11 years ago
Why does it work within IIS6 on .Net 4 or 3.5 and not in IIS7 with either 4 or 3.5?

Same code same DB.