YAFLogo

kavit
  • kavit
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
11 years ago
i had YAF 1.9.4 on my website .i disable new registration and login is required but lost password does nothing and redirect to login page. so please provide me solution for that in 1.9.4 not 1.9.5 i dont want to upgrade my forum.please provide me solutionas fast as posible i had read one threse but that is not correct or something wrong with it.

Thanks in Advanced

Sponsor
squirrel
11 years ago
Originally Posted by: kavit 

i had YAF 1.9.4 on my website .i disable new registration and login is required but lost password does nothing and redirect to login page. so please provide me solution for that in 1.9.4 not 1.9.5 i dont want to upgrade my forum.please provide me solutionas fast as posible i had read one threse but that is not correct or something wrong with it.

Thanks in Advanced

The solution will be to upgrade. I recommend v1.9.5.5 when it is release as stable. Because this software evolves through the support of users and their assistance to the development team, they don't go 'back' and update old versions with fixes. They include the fixes in the new version and release that.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
cagliostro
11 years ago
Originally Posted by: kavit 

i had YAF 1.9.4 on my website .i disable new registration and login is required but lost password does nothing and redirect to login page. so please provide me solution for that in 1.9.4 not 1.9.5 i dont want to upgrade my forum.please provide me solutionas fast as posible i had read one threse but that is not correct or something wrong with it.

Thanks in Advanced

You mean you lost your admin pass ?

If you have direct access to your MS SQL database you could edit the admin password (encrypted but there are some ready-encrypted password).

I don't know if that could work with YAF. I have done it with other software but not with YAF.

If the above works, and you find the admin pass field, then change it to

351573d8d5d08010146c74bbec7ad56d9b6aea43eca703848e0a56045f27ee93

and the password for the above is

qs

Of cource backup ypur DB first


kavit
  • kavit
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
11 years ago
But the problem with that when we upgrade to new version it will reset all users password i try a lot but i cant upgrade with same username and password please help me in 1.9.4 one solution would be there but its not affecting my file.
squirrel
11 years ago
Originally Posted by: kavit 

But the problem with that when we upgrade to new version it will reset all users password i try a lot but i cant upgrade with same username and password please help me in 1.9.4 one solution would be there but its not affecting my file.

I don't know of any upgrade to YAF that resets all users passwords.


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
cagliostro
11 years ago
I don't really understand what an upgrade has to do with a admin lost password....


tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
11 years ago
Originally Posted by: cagliostro 

I don't really understand what an upgrade has to do with a admin lost password....

He is talking about the "Lost Password" function in general, not the lost admin password

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
11 years ago
Originally Posted by: kavit 

But the problem with that when we upgrade to new version it will reset all users password i try a lot but i cant upgrade with same username and password please help me in 1.9.4 one solution would be there but its not affecting my file.

If you are unable to upgrade you have to modify and compile the source code yourself.

All infos what to change are posted here:

http://forum.yetanotherforum.net/yaf_postsm43946_-Lost-Password--option-does-nothing.aspx#post43946 

you have to modify the file PageSecurityModel.cs

Remove the lines...


case ForumPages.recoverpassword:
if (PageContext.BoardSettings.DisableRegistrations)
{
//problem code below
YafBuildLink.AccessDenied();
}

break;

and change line

// no security features for login/logout pages
if (ForumPageType == ForumPages.login || ForumPageType == ForumPages.approve || ForumPageType == ForumPages.logout)

to

// no security features for login/logout pages
if (ForumPageType == ForumPages.login || ForumPageType == ForumPages.approve || ForumPageType == ForumPages.logout || ForumPageType == ForumPages.recoverpassword)

Ps: yaf doesnt resets passwords on an ugrade.