• aBu-S3ayeD
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
12 years ago
i have uploaded my website then installing it on web host server every thing went fine except that i get
Security Exception when trying to access admin cp
i thought maybe my web host is blocking something so i contact them and they give the setting for there server
"web.config" and "legacy.web_mediumtrust.config"
next step i did was hosting the webstie in my machine,with same setting the host gave me
but the only changes i made in "web.config located in
change trust level from full to medium

Security Exception came back
ive tried to add few lines in yaf web.confog like
requirePermission="false" ,
nothing seems to work

the only thing has worked is changing the trust level my machine to full which i cant in web host server
any suggestion?

  • aBu-S3ayeD
  • 51.8% (Neutral)
  • YAF Forumling Topic Starter
12 years ago
i found out whats the problem
yaf didnt work with asp.net version 4.0 only with 2.0 (which is same 3.5)

sending email to my web host right now so they change the version:cheesy:
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
12 years ago
This is a known Problem YAf and .NET 4.0 wit medium trust, didnt work because of the DNA Controls used for admin Menu. I think this will be fixed in YAF 2.0, until then stick to .net 3.5 sp1
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button