YAFLogo

Palos
  • Palos
  • 56.6% (Neutral)
  • YAF Camper Topic Starter
12 years ago
Greetings everyone... i've been successful integrating yaf in my login by following zeee post.. but the problem that occurred is redirecting the url in my log in page when the user is logged out and tries to access the forum.. i modified the forum's setting into "only user's are allowed to view the forum" so i'm expecting the guest will be redirected into my log in page...

The error is http://localhost:2198/MYpage/forum/default.aspx?g=info&i=4

"The page isn't redirecting properly"

Below is my UrlRewriter.config in my YAF-v1.9.4-FINAL-SRC

<rewriter>
	<rewrite url="^~/(.+?)?yaf_login?\.aspx\?returnurl\=(.+)$" to="~/$1Default.aspx?g=login&amp;ReturnURL=$2" processing="stop" />
	<rewrite url="^~/(.+?)?yaf_info?\.aspx\?i=([0-9]+?)&amp;url\=(.+)$" to="~/$1Default.aspx?g=info&amp;i=$2&amp;url=$3" processing="stop" />
	<rewrite url="^~/(.+)?yaf_topics([0-9]+)p([0-9]+)(_([-a-z0-9]+))?\.aspx(\?(.+))?$" to="~/$1Default.aspx?g=topics&amp;f=$2&amp;p=$3&amp;$7" processing="stop" />
	<rewrite url="^~/(.+)?yaf_topics([0-9]+)(_([-a-z0-9]+))?\.aspx(\?(.+))?$" to="~/$1Default.aspx?g=topics&amp;f=$2&amp;$6" processing="stop" />
	<rewrite url="^~/(.+)?yaf_forum([0-9]+)(_([-a-z0-9]+))?\.aspx(\?(.+))?$" to="~/$1Default.aspx?g=forum&amp;c=$2&amp;$6" processing="stop" />
	<rewrite url="^~/(.+)?yaf_postst([0-9]+)p([0-9]+)(_([-a-z0-9]+))?\.aspx(\?(.+))?$" to="~/$1Default.aspx?g=posts&amp;t=$2&amp;p=$3&amp;$7" processing="stop" />
	<rewrite url="^~/(.+)?yaf_postst([0-9]+)(_([-a-z0-9]+))?\.aspx(\?(.+))?$" to="~/$1Default.aspx?g=posts&amp;t=$2&amp;$6" processing="stop" />
	<rewrite url="^~/(.+)?yaf_postsm([0-9]+)(_([-a-z0-9]+))?\.aspx(\?(.+))?$" to="~/$1Default.aspx?g=posts&amp;m=$2&amp;$6" processing="stop" />
	<rewrite url="^~/(.+)?yaf_profile([0-9]+)(_([-a-z0-9]+))?\.aspx(\?(.+))?$" to="~/$1Default.aspx?g=profile&amp;u=$2&amp;$6" processing="stop" />
	<rewrite url="^~/(.+)?yaf_([-0-9a-z_]+?)\.aspx\?(.+)?$" to="~/$1Default.aspx?g=$2&amp;$3" processing="stop" />
	<rewrite url="^~/(.+)?yaf_([-0-9a-z_]+?)\.aspx$" to="~/$1Default.aspx?g=$2" processing="stop" />
</rewriter>

i tried to modify the beginning rewrite url line into this:

<rewrite url="^~/forum/(.+?)?yaf_login?\.aspx\?returnurl\=(.+)$" to="~/login.aspx?ReturnURL=$2" processing="stop" />

unfortunately same error:cry: please help me out.. thanks

Sponsor