YAFLogo

chadclund
  • chadclund
  • 53.8% (Neutral)
  • YAF Forumling Topic Starter YAF Version: unknown
9 months ago
New install (today). I have to manually go into server and set write permissions for App_Data folder and Uploads folder.
However, images attached to new posts do NOT show in the posts, but they do show in the admin.
Please see attached screenshots
 Screenshot 2023-03-07 at 13-42-03 User Attachments · Escort Access Forums.png You have insufficient rights to see the content. Screenshot 2023-03-07 at 13-41-37 Test 4 with image · Escort Access Forums.png You have insufficient rights to see the content.
Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
9 months ago
Thanks for your reply. This is a known issue and will be fixed in the next YAF Release 3.13 (which will be released this weekend).

As a workaround you need to manually import the needed BBCode Extensions via... Admin > Settings > BBCode Extensions > Import List with the BBCodeExtensions.xml (this file can be found in the install folder)
OrdinaryNimda
  • OrdinaryNimda
  • 80.2% (Honored)
  • YAF Forumling YAF Version: 3.1.13
8 months ago
The attached image is not displaying inline in 3.1.13 (but it did work in 3.1.12). There is only a link of the Attached image, which is then downloaded as a general file.
Was there any change done in 3.1.13 to the Attachment functionality?
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
8 months ago
If the image is only displayed as link and not as image then the image is to big. This has not been changed in the latest version.

This setting was added in 2009. Under Host > Host Setup > Image Attachment & Resize Settings > Image Attachment Display Threshold you can define the maximum size of the image before its shown as links. (The value is in bytes)
OrdinaryNimda
  • OrdinaryNimda
  • 80.2% (Honored)
  • YAF Forumling YAF Version: 3.1.13
8 months ago
Oh, I see this, absolutely correct behavior for a forum!
(For some reason I thought this will force a resize, which of course cannot be the case.)
smn
  • smn
  • 55.6% (Neutral)
  • YAF Forumling YAF Version: 3.1.13
8 months ago
User posted images do not keep the aspect ratio when resized, but are stretched in the X axis on a big screen. Can you please fix this, for example by expressing max-width in percentages:

<div class="card bg-dark text-white" style="max-width:25%"><a href="/resource.ashx?i=60&amp;b=1" title="IMG_20230407_134916.jpg" data-gallery="#blueimp-gallery-736"><img src="/resource.ashx?p=60&amp;b=1" alt="IMG_20230407_134916.jpg" class="img-user-posted card-img-top"></a><div class="card-body py-1"><p class="card-text small">Click to View Image<span class="text-muted float-end">1 View(s)</span></p></div></div>


 
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
8 months ago
Can you post a sample image so i can try to reproduce it?

 high.png You have insufficient rights to see the content.

 wide.png You have insufficient rights to see the content.
smn
  • smn
  • 55.6% (Neutral)
  • YAF Forumling YAF Version: 3.1.13
7 months ago
You can see it here:

https://hyde-park.si/Posts/t75-Pouhna-luna-in-kraljica-Julijcev 

Image Attachment & Resize Settings:
Enable Image Attachment Resize: ON
Resize User Posted Images: ON
Thumbnail Image Resize Max Width 732, Max Height 732
Image Resize Max Width 1024, Max Height 1024
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
7 months ago
 test.jpg You have insufficient rights to see the content.

adding the object-fit property seems to fix it.
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button