YAFLogo

OrdinaryNimda
  • OrdinaryNimda
  • 69.4% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.12
a month ago
Originally Posted by: tha_watcha 

I don't think I can't fix that.  I tested 4 different dann installations and can't reproduce the errors.

Can you post your web.config after the install?

Does the forum show data as guest user?

I am providing web-configs (before/after install v3_6118), and only changed the SQL password to "XXXXX". 

 web_Configs.zip You have insufficient rights to see the content.

I just found and fixed one error: in the \DesktopModules\YetAnotherForumDotNet\langues\ folder I made a copy of the file english.xml into english - Copy.xml ... (there must be a reference to it somewhere) and now there is no more PersonaBar error after v3_6118. (EDIT: I can confirm this behavior even after IIS Service re-start, so this is good.)

However, after the upgrade, the YAF database "looks empty" with the text "Currently the Forum doesnt contain any Messages." for the YAF.WhatsNew module on the first page, and is totally empty on any of the YAF.Module pages. This is for all users Guest, Normal, and also Host..

(EDIT: I restored everything back to the old version, including the SQL, just in case.)

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
a month ago
i updated the module again..

https://github.com/YAFNET/YAFNET-DNN/releases/tag/v3.1.6-6118 

another fix attempt

I see that one user has in the yaf_User table the language file english - copy.json in the column LanguageFile. Change it to english.json or create the file in the languages folder.

OrdinaryNimda
  • OrdinaryNimda
  • 69.4% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.12
a month ago
I tried it, and have the same error situation, with no YAF data in the WhatsNew and YAF forum module. now

SQL: yaf_User table has the column LanguageFile with NULL values for ALL users, before and after upgrade. I will check the file system for references to "english - copy". (EDIT: no text files contain this; I will check the file yafdnn-res.zip.manifest on the next upgrade, I confirm it is not there in the previous version, only english.xml).

Also, there would be the unresolved popper.js error, so I added this as HTML markup to the default.aspx so it works without JS errors until this issue is resolved.

[script src="https://unpkg.com/@popperjs/core@2"][/script]

 

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
a month ago
Quote:

SQL: yaf_User table has the column LanguageFile with NULL values for ALL users, before and after upgrade. I will check the file system for references to "english - copy". (EDIT: no text files contain this; I will check the file yafdnn-res.zip.manifest on the next upgrade, I confirm it is not there in the previous version, only english.xml).

Then the setting is in the HostSettings yaf_Registry table under Name = language, Value = 'english - copy.json'

Quote:

I tried it, and have the same error situation, with no YAF data in the WhatsNew and YAF forum module. now

It seems there is something wrong with the yaf table. I assume the ActiveAcess table is empty after you load the page with the Whats New module or the Forum Module.

Would it be possible to send me all yaf_xxx tables as exported sql file to my mail address support@yetanotherforum.net? So i can check the data and reproduce the issue.

OrdinaryNimda
  • OrdinaryNimda
  • 69.4% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.12
a month ago
Yes, I will send everything, give me some time., maybe half and hour so.

EDIT: yaf_Registry DOES contain a Name = 'language' and value = 'english - Copy.xml' row.

RegistryID    Name    Value    BoardID
5    language    english.xml    NULL
10    language    english - Copy.xml    1

EDIT: the SQL db locale is "slovenian". So i will export to UNICODE. However, it can also be english or german, or whatever you will specify, if this is not OK.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
a month ago
I seemed to have compiled the wrong package. Updated version again..

https://github.com/YAFNET/YAFNET-DNN/releases/tag/v3.1.6-6118 

 

OrdinaryNimda
  • OrdinaryNimda
  • 69.4% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.12
a month ago
This is interesting now! 

1) Install 100% success.

2) Restarting IIS...

3) There IS forum content on YAF.WhatsNew and YAF.Forum modules!! Clicking YAF.WhatsNew goes to the proper forum message. This is good... 😁

4) However, now PersonaBar is not working, bootstrap, jquery and other JS errors are the source of error, images are not visible. (I deleted the reference to Popper.JS from the popper server, but it does not change behavior. In the previous version, referencing Popper.js helped to clear all JS errors.)

I will do what you ask here.

(I have tried fiddling with the sql data export and I can do it, but will need more time. Either manually exporting data for each yaf_Table, which I can do, or SQL Notebook for a notebook file. This is because I only have the SQL Express version, no wizard for multiple tables export. On the other hand, I can send you the whole DNN database, if it would be easier for you. But I think the database part of YAF is now operational.)

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
a month ago
Okay if the forum shows up, then you don't need to send me the data. It's likely an js issue.

Are you have any js issues in the browser console?

Did you try to clear the browser cache or reload the page via ctrl+ F5?

 

OrdinaryNimda
  • OrdinaryNimda
  • 69.4% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.12
a month ago
Before, I forgot about "english - Copy.xml", if is still referenced in the new version. Later today I will do the update Extension proc again and check this explicitely. However, in the prev versions, manual insertion of Popper.js into default.aspx solved all JS problems, now it does not...  Will report back today or later.
OrdinaryNimda
  • OrdinaryNimda
  • 69.4% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.12
a month ago
UPDATE #2:

The forum runs normally with SQL database on v5_6118, but with old files (6113...). Extension says 6118 in the Extension manager, but the files are 6113. (One example, DELETE MESSAGE dow not work in that version, which you fixed some time ago. The editor shows "AUTOSAVE" in green on the client area, etc.

But it does not run with 6118 files. The PersonaBar does not work and the static elements are invalid/missing. Of course I tried deleting all cached web file elements, the F12 console shows the same error 500 errors. (I did not know, that POPPER is part of the bootstrap library until now.) So, there is a faulty reference somewhere in the files. Of course this does not mean, that it is because of YAF, the error could be originating from anywhere, as far as I know my Math. I also made a copy of "english - Copy.json", but it does not change anything.

I have to restore the old working version, because PersonaBar must be running for Admin or Host. If I get new ideas to test, I will do the Extension update again. It only takes a few minutes to restore the old version. Thank heavens this is a very small website forum (except for the millions of search engines).

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
a month ago
Does the personabar doesnt work on all pages? If it is a javascript issue then the issue would occur only on the pages with the yaf module and the yaf whats new module on. Otherwise there would be an error logged to the log files.

Yaf does indeed load the bootstrap libary inluding popper. But the default theme in dnn loads an older bootstrap libary. If both are loaded then its causing trouble. As i wrote before the correct way would be to load the libary in the theme via the client resource management api as i wrote here...

https://yetanotherforum.net/forum/Posts/m73302-Errors-upgrading-to-3-13 

OrdinaryNimda
  • OrdinaryNimda
  • 69.4% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.12
a month ago
Yes, I implemented those changes at the time. Switching to one of the newest YAF skins (YAF) solved the problem. And deleted all older skins and also updated the 3rd party skin ascx files with the directives you gave. 👍 Since then, there are no more Javascript problems in the "current old version". There is no errors or severe warnings on any pages with WhatsNew and YafModule on the working version.

I have found a great utility WinMerge for folder comparisons. There is something interfering with the newest version, maybe even a "typo" somewhere. This does not mean that the source is YAF, it could be from anywhere. If I find anything relevant, I will inform you here. The goal is to have the YAF Module running on 6118 which has great improvements.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
a month ago
Sorry but at this point i cant help you, if you keep mixing up versions.

If there are no more javascript errors, and the personabar didnt work on all dnn pages then the issue is likly caused by a depending assembly reference in the web.config.

Are there are anymore issues in the log files? You can also access the files which throw an 500 error in the browser console. directly via url to see the error

OrdinaryNimda
  • OrdinaryNimda
  • 69.4% (Friendly)
  • YAF Forumling Topic Starter YAF Version: 3.12
a month ago
You have done the upgrade 100% for the YAF part of the forum software. And I thank you for that!

I have just found there is one bootstrap.min.css.map warning on a page, that has no YAF component. So not YAF dependent error at all. And that stems from doing DNN upgrades. I only fiddle with the presentation layer of the website, so ASCX and maybe some CSS. Or include CSS styles directly in ASCX, so there is no fiddling with JS at all, including the boostrap libraries. I wouldn't touch that with a 10-foot barge-pole, let alone a debugger.😁

I will notify here if I succeed in cleaning up the errors. Maybe it can help other users on DNN.