universesolved
2021-06-13T19:01:53Z
Hi, I am running YAF 1.9.1.2 on a Windows server hosted by GoDaddy. They had upgraded the IIS version last year and I recently noticed that, since then, there have been no new registrants in my forum. So I tested it by attempting to register with a different email address. The problem turned out to be that when I received my verification email, the URL string was non-secure, as shown below. Clicking on the link results in a "Site can't be reached page". When I replaced "http" with "https", everything was fine, but my users won't think to do that. Is there a URL string definition somewhere where I can stick the "s" in? (Note: the web.config file does have a redirect rule, but for some reason it doesn't work in this case)

Thanks very much!

You have requested to join Programmed Reality, but before you can join your email address must be verified.

To verify your email address open the following link in your web browser:

<http://theuniversesolved.com:443/yetanotherforum/default.aspx?g=approve&k=<hidden>>

Your approval key is:
<hidden>

http://theuniversesolved...rum/default.aspx?g=forum 
Sponsor
tha_watcha
2021-06-14T03:30:00Z
The base url mask can be set in the board settings, that is used for email links.

However you should set a rewrite rule to automatically redirect all http to https

https://ca.godaddy.com/h...in-windows-hosting-27873 
UserPostedImage
universesolved
2021-06-14T18:09:17Z
Hello, thanks very much for your quick response.

I don't think the URL mask can be set in Board Settings in version 1.9.1.2. I'm attempting to upload a screen shot.

I had also tried that exact code snippet that you pointed me to, both in the web.config file at the root of the server, at one level above the YAF directory (my domain level), and at the YAF directory level. In the latter case, it seemed to break the Forum access so I took it out. In the other two instances, there was no change in behavior.

board settings.png

Click to View Image7 View(s)

tha_watcha
2021-06-16T05:58:16Z
Quote:

. In the latter case, it seemed to break the Forum access so I took it out. In the other two instances, there was no change in behavior.



What is the problem? Atleast on my test installation the rewrite setting works
UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved