YAFLogo

rai
  • rai
  • 100% (Exalted)
  • YAF Commander Topic Starter
3 years ago
Since I upgrade to latest everything is messed up. The new default settings (never changed this before) caused all uploads to be of size 200x200. I tried to change to adapt but now it is a mess.

Can someone please post the right default settings to use and let me know if this issue is fixed?

I also wonder if changing the settings also changes existing uploading images because my whole site is messed up at the moment.

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
You can change the default settings in the host settings.

You might need to Restart the application to see the changes. Or clear the caches via the host settings

rai
  • rai
  • 100% (Exalted)
  • YAF Commander Topic Starter
3 years ago
Thanks, but since there seems to be some kind of delay in updating these and seeing the result it is hard to test in production. Now, the defaults of latest version is set back again but still I am experiencing the same issue as just after upgrade. What happens is that all thumbnail images now are 200x200 (as before which is correct) but also all uploaded images are 200x200 (independent of original size). Previously, when clicking on thumbnail I would get a popup with original language. How can I restore that? Here are my current settings:

https://www.screencast.com/t/fE9dTZqox 

Thanks again!

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
Originally Posted by: rai 

Thanks, but since there seems to be some kind of delay in updating these and seeing the result it is hard to test in production. Now, the defaults of

Did you read my message above? The settings are cached if you change them restart the application or Clear all caches via the host settings. You can also deactivate the resizing via the host setting Enable Image Attachment Resize

rai
  • rai
  • 100% (Exalted)
  • YAF Commander Topic Starter
3 years ago
Originally Posted by: tha_watcha 

Originally Posted by: rai 

Thanks, but since there seems to be some kind of delay in updating these and seeing the result it is hard to test in production. Now, the defaults of

Did you read my message above? The settings are cached if you change them restart the application or Clear all caches via the host settings. You can also deactivate the resizing via the host setting Enable Image Attachment Resize

I did restart the W3C Windows service each time to be sure. I disabled "Enable Image attachment Resize" but still upload images are not larger than thumbnail.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
Originally Posted by: rai 

Originally Posted by: tha_watcha 

Originally Posted by: rai 

Thanks, but since there seems to be some kind of delay in updating these and seeing the result it is hard to test in production. Now, the defaults of

Did you read my message above? The settings are cached if you change them restart the application or Clear all caches via the host settings. You can also deactivate the resizing via the host setting Enable Image Attachment Resize

I did restart the W3C Windows service each time to be sure. I disabled "Enable Image attachment Resize" but still upload images are not larger than thumbnail.

But looking at your screen shot the settings still shows 200 x 200 so of course all images getting resized on image upload if there are bigger. If you would increase the the values new uploads would be bigger. Depending on what value you enter. Of course existing uploads that where automatically resized cant be fixed.

rai
  • rai
  • 100% (Exalted)
  • YAF Commander Topic Starter
3 years ago
I assume this is new behavior? What happened before was that the image uploaded was not resized but kept in original size. This sounds most natural to avoid scaling issues (down or up) which results in fuzzy images or similar?
rai
  • rai
  • 100% (Exalted)
  • YAF Commander Topic Starter
3 years ago
Doing further testing. I increase this value to 900x900. The problem is now that I do not get my thumbnails. Instead I get 900x900 images right in the forum - I want the previous behavior with thumbnails. Furthermore, another issue is that the uploaded image is not shown in original size. It also is resized to 900x900. Something is really wrong with the new resizing. I am attaching my current settings:

https://www.screencast.com/t/0AmAFI1Y 

How do I change it back so that thumbnails are 200x200 but when clicking on thumbnail I get image with original size. This was the old behavior.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
Originally Posted by: rai 

Doing further testing. I increase this value to 900x900. The problem is now that I do not get my thumbnails. Instead I get 900x900 images right in the forum - I want the previous behavior with thumbnails. Furthermore, another issue is that the uploaded image is not shown in original size. It also is resized to 900x900. Something is really wrong with the new resizing. I am attaching my current settings:

https://www.screencast.com/t/0AmAFI1Y 

How do I change it back so that thumbnails are 200x200 but when clicking on thumbnail I get image with original size. This was the old behavior.

Of course if you disable the image attachment resize the images show up in the orignal size without thumbnails. This behavior has not been changed

rai
  • rai
  • 100% (Exalted)
  • YAF Commander Topic Starter
3 years ago
Originally Posted by: tha_watcha 

Originally Posted by: rai 

Doing further testing. I increase this value to 900x900. The problem is now that I do not get my thumbnails. Instead I get 900x900 images right in the forum - I want the previous behavior with thumbnails. Furthermore, another issue is that the uploaded image is not shown in original size. It also is resized to 900x900. Something is really wrong with the new resizing. I am attaching my current settings:

https://www.screencast.com/t/0AmAFI1Y 

How do I change it back so that thumbnails are 200x200 but when clicking on thumbnail I get image with original size. This was the old behavior.

Of course if you disable the image attachment resize the images show up in the orignal size without thumbnails. This behavior has not been changed

So, how can I have the original behavior? Thumbnail 200x200 and full image size when clicking on thumbnail?

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
Turn on again the setting enable image attachment resize and. Choose a big value like 2000 x 2000.
rai
  • rai
  • 100% (Exalted)
  • YAF Commander Topic Starter
3 years ago
Originally Posted by: tha_watcha 

Turn on again the setting enable image attachment resize and. Choose a big value like 2000 x 2000.

What happens then;

1280x800 jpg file - this becomes a link and not a preview. Clicking on it downloads it - I would like to see a thumbnail

3800x2500 jpg file - this becomes a link and not a preview. Clicking on it downloads it - I would like to see a thumbnail

150x100 png file - this becomes stretched to 2000x2000 - really weird...

What is going on?

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
Originally Posted by: rai 

1280x800 jpg file - this becomes a link and not a preview. Clicking on it downloads it - I would like to see a thumbnail

3800x2500 jpg file - this becomes a link and not a preview. Clicking on it downloads it - I would like to see a thumbnail

That is correct and the default behavior. this has not been changed. If the file size is too big it will be displayed as link. You can increase the byte value in the host setting under Image Attachment Display Threshold

Originally Posted by: rai 

150x100 png file - this becomes stretched to 2000x2000 - really weird...

Yes indeed i can confirm this. This is a bug. Will be fixed with the next update!

rai
  • rai
  • 100% (Exalted)
  • YAF Commander Topic Starter
3 years ago
Thanks, what about controlling which types? I would like to see jpg having same behavior as png. But maybe it is something about the size?

Personally I would like to see two settings:

Size of thumbnail

Max size of image

These are two different things that I feel are conflictning now. If not, the 200x200 default for thumbnail is fine.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 仍 YAF Version: 3.0.3
3 years ago
Version 2.24.17 has been released. The thumbnails are not fixed to max. 200x200