YAFLogo

Rawbert
  • Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
10 years ago
Upgrade from 2.1.1 was successful, but can't access any forums, posts or member list, I get the resource not found error.
I also pasted the General Exception from Admin> Event Viewer (I was getting this GE before the upgrade too btw).
____________________
Server Error in '/' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /DesktopModules/YetAnotherForumDotNet/yaf_topics20_Introductions.aspx

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.17929
__________________________________________
Error in event viewer:

InnerException:Cannot insert the value NULL into column 'RankID', table 'dnn.dbo.yaf_User'; column does not allow nulls. INSERT fails. The statement has been terminated.

FileName:

FileLineNumber:0

FileColumnNumber:0

Method:System.Data.SqlClient.SqlConnection.OnError

StackTrace:

Message:

System.Data.SqlClient.SqlException (0x80131904): Cannot insert the value NULL into column 'RankID', table 'dnn.dbo.yaf_User'; column does not allow nulls. INSERT fails.
The statement has been terminated.
at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite)
at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite)
at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite)
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at YAF.Core.Data.DbAccessBase.Execute[T](Func`2 execFunc, IDbCommand cmd, IDbTransaction dbTransaction)
at YAF.Classes.Data.LegacyDb.user_save(Object userID, Object boardID, Object userName, Object displayName, Object email, Object timeZone, Object languageFile, Object culture, Object themeFile, Object textEditor, Object useMobileTheme, Object approved, Object pmNotification, Object autoWatchTopics, Object dSTUser, Object hideUser, Object notificationType)
at YAF.DotNetNuke.Components.Utils.UserImporter.CreateYafUser(UserInfo dnnUserInfo, MembershipUser dnnUser, Int32 boardID, Int32 portalID, YafBoardSettings boardSettings)
at YAF.DotNetNuke.Components.Utils.UserImporter.ImportUsers(Int32 boardId, Int32 portalId, Guid portalGUID, String& info)
ClientConnectionId:52381225-8808-4ace-a558-c4aa53b199be

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
Originally Posted by: Rawbert 

Upgrade from 2.1.1 was successful, but can't access any forums, posts or member list, I get the resource not found error.



are all urls contain the "/DesktopModules/YetAnotherForumDotNet/" Which DNN version did you use?

Which friendlyurl provider did you use in dnn, and with which settings?

Regarding the event log error. The error occurs because there is no Rank found in your board which has the flag IsStart set. Check your Ranks and make sure that one Rank has that flag set.

Rawbert
  • Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
10 years ago
Originally Posted by: tha_watcha 

Originally Posted by: Rawbert 

Upgrade from 2.1.1 was successful, but can't access any forums, posts or member list, I get the resource not found error.



are all urls contain the "/DesktopModules/YetAnotherForumDotNet/" Which DNN version did you use?

Which friendlyurl provider did you use in dnn, and with which settings?

Regarding the event log error. The error occurs because there is no Rank found in your board which has the flag IsStart set. Check your Ranks and make sure that one Rank has that flag set.



I recall they all do. I use the latest DNN, 7.2.2.
I didn't use any 3rd party url providers before, but I did turn on the built in DNN advanced url management a month or so ago, but yaf was working fine after I did that.
When I did that the .aspx extension disappeared from all my links and now yaf is looking for it that could be the problem?
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
uploaded BETA 2, if it still don't work try to disable url rewriting for the module in the web.config in the appsettings

<add key="YAF.EnableURLRewriting" value="false" />
Rawbert
  • Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
9 years ago
Originally Posted by: tha_watcha 

uploaded BETA 2, if it still don't work try to disable url rewriting for the module in the web.config in the appsettings

<add key="YAF.EnableURLRewriting" value="false" />



now I get a 403:

403 - Forbidden: Access is denied.
You do not have permission to view this directory or page using the credentials that you supplied.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
9 years ago
So do all urls still look like this

/DesktopModules/YetAnotherForumDotNet/yaf_topics20_Introductions.aspx ?

Those links should not look like this if you are using the beta version. Or how do the urls look now at your site?
Rawbert
  • Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
9 years ago
Originally Posted by: tha_watcha 

Originally Posted by: Rawbert 

Upgrade from 2.1.1 was successful, but can't access any forums, posts or member list, I get the resource not found error.



are all urls contain the "/DesktopModules/YetAnotherForumDotNet/" Which DNN version did you use?

Which friendlyurl provider did you use in dnn, and with which settings?

Regarding the event log error. The error occurs because there is no Rank found in your board which has the flag IsStart set. Check your Ranks and make sure that one Rank has that flag set.



The "Newbie" rank has the flag IsStart to Yes.
Rawbert
  • Rawbert
  • 94.2% (Exalted)
  • YAF Commander Topic Starter
9 years ago
Originally Posted by: tha_watcha 

uploaded BETA 2, if it still don't work try to disable url rewriting for the module in the web.config in the appsettings

<add key="YAF.EnableURLRewriting" value="false" />



Setting the url to false did the trick, thanks watcha!

Quick question, is it OK to use the beta versions in a production environment?
I just want to make sure the upgrade from beta to a stable release is supported.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
9 years ago
Yes, this beta is safe to use in production, because it contains only bug fixes. Also upgrading from beta to release is supported.

Release of 2.1.2 hopefully soon.
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button