YAFLogo

Dracus
  • Dracus
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
8 years ago
Hi all,

I just upgraded from 1.9.1 to 2.1.0 and cannot login with old member.

I am getting "The username or password is incorrect. Please try again".

When I register new member I see entry in DB but login also does not work.

From Event Log I see:

Event code: 4005

Event message: Forms authentication failed for the request. Reason: The ticket supplied was invalid.

Any idea how to recover login for old members and what to do for new ones?

Thanks,

Dracus

Sponsor
jen4937775
8 years ago
I encountered the same problem. Can't login yaf in version 2.0.0. This yaf instance has been integrated to Umbraco. I need to log in Umbraco back office first then I can log in yaf. Does any one know what happened?

Following is the error message I got from event log.

Exception System.NullReferenceException: Object reference not set to an instance of an object. at PMS.Core.EventHandler.Member.Member_AfterSave(Member sender, SaveEventArgs e) at umbraco.cms.businesslogic.member.Member.SaveEventHandler.Invoke(Member sender, SaveEventArgs e) at umbraco.cms.businesslogic.member.Member.FireAfterSave(SaveEventArgs e) at umbraco.cms.businesslogic.member.Member.Save() at umbraco.providers.members.UmbracoMembershipProvider.ValidateUser(String username, String password) at YAF.Pages.login.GetValidUsername(String username, String password) at YAF.Pages.login.Login1_Authenticate(Object sender, AuthenticateEventArgs e) at System.Web.UI.WebControls.Login.OnAuthenticate(AuthenticateEventArgs e) at System.Web.UI.WebControls.Login.AttemptLogin() at System.Web.UI.WebControls.Login.OnBubbleEvent(Object source, EventArgs e) at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) at System.Web.UI.WebControls.Button.OnCommand(CommandEventArgs e) at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) at System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Dracus
  • Dracus
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
8 years ago
Anybody with similar issue?
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
8 years ago
Originally Posted by: Dracus 

Anybody with similar issue?

Well one reason for the login problem could be, that on upgrade you override the web.config and the machine key is different from the previous version.

Dracus
  • Dracus
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
8 years ago
Thanks for reply.

I checked old web.config and there I did not have machine key.

Also in new web.config I do not use machine key.

From commented lines I see that machine key should be used in case:

and I do not have this type of scenario.

Any other suggestion?

Thanks in advance

Dracus
  • Dracus
  • 52.4% (Neutral)
  • YAF Forumling Topic Starter
8 years ago
After creating new user when I validate email and try to login again I see

Failure Initializing User/Page. System.ApplicationException: Unable to find the Guest User! at YAF.Core.LoadPageFromDatabase.Handle(InitPageLoadEvent event)

Btw. new users are created in table yaf_prov_Membership and not any more in yaf_Users.

Of course, as old users are in yaf_Users table I cannot login any more with any of old users.

Is there any way to switch back to yaf_Users table?

Thanks