YAFLogo

hasibul2363
  • hasibul2363
  • 53% (Neutral)
  • YAF Forumling Topic Starter
13 years ago
I am using YAF 1.9.4

Unable to send mail from YAF.
I have installed YAF on my pc.

I have configured my mail.config and app.config file but still unable to send mail from YAF.
My configuration as follows

app.config file:
<add key="YAF.UseSMTPSSL" value="true" /> [/code] 

mail.config file

[code]<smtp deliveryMethod="Network" from="admin@e-rains.com">
	<!-- Uncomment to specify SMTP settings -->
  <network host="smtp.gmail.com" port="465" password="####" userName="admin@e-rains.com" />
</smtp>

<!-- Use this setting for development: pickup directory must be exact path -->
<smtp deliveryMethod="SpecifiedPickupDirectory">
	<specifiedPickupDirectory pickupDirectoryLocation="C:\Inetpub\wwwroot\email" />
</smtp>


But it showes following error

Failed to connect:

' ' is an unexpected token. The expected token is '>'. Line 8, position 92. (C:\inetpub\vhosts\e-rains.com\subdomains\forum\httpdocs\mail.config line 8)


if i disabled following section

<!-- smtp deliveryMethod="SpecifiedPickupDirectory">
	<specifiedPickupDirectory pickupDirectoryLocation="C:\Inetpub\wwwroot\email" />
</smtp-->

then it is loading and loading..

What will be solution??
I have searched several forum post but unable to find solution.


waiting for help......
Sponsor

Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
13 years ago
your mail.config should look like this:


<smtp deliveryMethod="Network" from="admin@e-rains.com">
  <network host="smtp.gmail.com" port="465" password="####" userName="admin@e-rains.com" />
</smtp>

with nothing else in it.
squirrel
13 years ago
Originally Posted by: Jaben 

your mail.config should look like this:


<smtp deliveryMethod="Network" from="admin@e-rains.com">
  <network host="smtp.gmail.com" port="465" password="####" userName="admin@e-rains.com" />
</smtp>

with nothing else in it.



Additionally, when sending from a gmail server, you will have to set the username to your gmail email account - not your forum's admin account. The username and password in your mail settings above need to reflect that of the account you are using on gmail to send the mail.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
hasibul2363
  • hasibul2363
  • 53% (Neutral)
  • YAF Forumling Topic Starter
13 years ago
Thanks for replay. finally able to configure smtp setting.

I have changer smtp port = 465 to 587. now it is working.
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
13 years ago
Glad you got it working 😉
dude0001
  • dude0001
  • 50.2% (Neutral)
  • YAF Forumling
11 years ago
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button