YAFLogo

mccutchen
  • mccutchen
  • 62% (Friendly)
  • YAF Camper Topic Starter
14 years ago
I just downloaded and installed the app today and having a issue with the setup. Here is what I did so someone please help if you can.

1. I have a Windows 2008 Server
2. I created a new site and uploaded the app to the root of the new site.
3. I copied the recommended file from the /webconfigs/ folder and renamed it web.config and it is in the root.
4. I created a SQL 2005 DB and associated datasource
5. I renamed the folder YetAnotherForum.NET to be YAF
6. I turned mode = off in webconfig
http://www.mydomain.com/YAF/install/default.aspx 

I get the following error when attempt to load this page:

Server Error in '/' Application.


Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0246: The type or namespace name 'YAF' could not be found (are you missing a using directive or an assembly reference?)

Source Error:

Line 102:
Line 103:
Line 104:
Line 105:
Line 106:

Source File: d:\inetpub\vhosts\mydomain.com\httpdocs\web.config Line: 104


Show Detailed Compiler Output:


C:\Windows\SysWOW64\inetsrv> "C:\Windows\Microsoft.NET\Framework\v3.5\csc.exe" /t:library /utf8output /R:"C:\Windows\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c561934e089\System.Xml.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Web.Services\2.0.0.0__b03f5f7f11d50a3a\System.Web.Services.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Configuration\2.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll" /R:"C:\Windows\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Windows.Forms\2.0.0.0__b77a5c561934e089\System.Windows.Forms.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Design\2.0.0.0__b03f5f7f11d50a3a\System.Design.dll" /R:"C:\Windows\assembly\GAC_32\System.EnterpriseServices\2.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.ServiceModel\3.0.0.0__b77a5c561934e089\System.ServiceModel.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Core\3.5.0.0__b77a5c561934e089\System.Core.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Runtime.Serialization\3.0.0.0__b77a5c561934e089\System.Runtime.Serialization.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Xml.Linq\3.5.0.0__b77a5c561934e089\System.Xml.Linq.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Data.Linq\3.5.0.0__b77a5c561934e089\System.Data.Linq.dll" /R:"C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorlib.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.ServiceModel.Web\3.5.0.0__31bf3856ad364e35\System.ServiceModel.Web.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.IdentityModel\3.0.0.0__b77a5c561934e089\System.IdentityModel.dll" /R:"C:\Windows\assembly\GAC_32\System.Data\2.0.0.0__b77a5c561934e089\System.Data.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Data.DataSetExtensions\3.5.0.0__b77a5c561934e089\System.Data.DataSetExtensions.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Web.Mobile\2.0.0.0__b03f5f7f11d50a3a\System.Web.Mobile.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.WorkflowServices\3.5.0.0__31bf3856ad364e35\System.WorkflowServices.dll" /R:"C:\Windows\assembly\GAC_32\System.Web\2.0.0.0__b03f5f7f11d50a3a\System.Web.dll" /out:"C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\6d7e2e60\ceb4ea6c\App_Code.62gu_e06.dll" /D:DEBUG /debug+ /optimize- /w:4 /nowarn:1659;1699;1701 /warnaserror- "C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\6d7e2e60\ceb4ea6c\App_Code.62gu_e06.0.cs" "C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\6d7e2e60\ceb4ea6c\App_Code.62gu_e06.1.cs"


Microsoft (R) Visual C# 2008 Compiler version 3.5.30729.1
for Microsoft (R) .NET Framework version 3.5
Copyright (C) Microsoft Corporation. All rights reserved.

d:\inetpub\vhosts\mydomain.com\httpdocs\web.config(104,30): error CS0246: The type or namespace name 'YAF' could not be found (are you missing a using directive or an assembly reference?)


I really appreciate any help to get this running.

Thanks
Sponsor

herman_herman
14 years ago
Make sure you have moved all DLLs inside NET2 or NET3.5 folders to the Bin root.
mccutchen
  • mccutchen
  • 62% (Friendly)
  • YAF Camper Topic Starter
14 years ago
I don't have BIN folder on my root. Do I need one?
mccutchen
  • mccutchen
  • 62% (Friendly)
  • YAF Camper Topic Starter
14 years ago
I created a folder call BIN on my root and copied the files from the /BIN/3.5 folder into it. Now I get the following error:
Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unable to open configSource file 'URLRewriter.config'.

Source Error:

Line 17:
Line 18:
Line 19:
Line 20:
Line 21:

repler
  • repler
  • 50.6% (Neutral)
  • YAF Forumling
14 years ago
I had the same issue when YAF was embedded within my pre-existing application. I checked IIS and the YAF subdirectory within my application was also marked as an application within IIS, so I set it back to a normal subdirectory and everything worked.

Here's the thread with that tip: http://forum.yetanotherforum.net/yaf_postst8400_CS0246-The-type-or-namespace-name-YAF-could-not-be-found.aspx 
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button