YAFLogo

ekaleido
  • ekaleido
  • 59.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
I just did a fresh install of 1.9.3 rc2 and when I attempt to register a new user I get the following:

Quote:


Security Exception
Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[SecurityException: Request for the permission of type 'System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.]
System.Security.CodeAccessSecurityEngine.Check(Object demand, StackCrawlMark& stackMark, Boolean isPermSet) +0
System.Security.CodeAccessPermission.Demand() +59
System.Reflection.Assembly.VerifyCodeBaseDiscovery(String codeBase) +118
System.Reflection.Assembly.get_CodeBase() +32
System.Web.Handlers.ScriptResourceHandler.GetCodeBaseWithAssert(Assembly assembly) +31
System.Web.Handlers.ScriptResourceHandler.GetLastWriteTime(Assembly assembly) +36
System.Web.Handlers.ScriptResourceHandler.GetAssemblyInfoInternal(Assembly assembly) +58
System.Web.Handlers.ScriptResourceHandler.GetAssemblyInfo(Assembly assembly) +59
System.Web.Handlers.RuntimeScriptResourceHandler.System.Web.Handlers.IScriptResourceHandler.GetScriptResourceUrl(Assembly assembly, String resourceName, CultureInfo culture, Boolean zip, Boolean notifyScriptLoaded) +336
System.Web.UI.ScriptManager.GetScriptResourceUrl(String resourceName, Assembly assembly) +114
System.Web.UI.ScriptRegistrationManager.RegisterClientScriptResource(Control control, Type type, String resourceName) +115
System.Web.UI.ScriptManager.RegisterClientScriptResource(Control control, Type type, String resourceName) +9


Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433



Any help is greatly appreciated.
Sponsor

ekaleido
  • ekaleido
  • 59.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
I shold note this same error occurs in the Admin CP when I list users and attempt to "Edit" any of the users. I have gone through and given read/write to EVERYONE for the entire directory structure, to no avail.
ekaleido
  • ekaleido
  • 59.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
It also returns the same error when I attempt to create a new access mask.
ekaleido
  • ekaleido
  • 59.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
Just for giggles I installed 1.9.1 and it worked. Then I upgraded, per the instructions, to 1.9.3rc2 and the same things are broken. What confuses me is why I can create frums, categories and edit profiles but the above items return permissions errors (apparently).
ekaleido
  • ekaleido
  • 59.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
Found the following. I don't use the SRC and have no way to build the software myself, however...

Quote:


Request for the permission of type 'System.Security.Permissions.FileIOPermission
Actually it was none of those. You can't access the web.config appsettings using: System.Web.Configuration.WebConfigurationManager on medium trust. I changed it to System.Configuration.ConfigurationManager after a couple hours of researching and it is fine now.

ekaleido
  • ekaleido
  • 59.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
I am also not allowed to try to bypass this by setting trust level in web.config. Apparently my host doesn't allow this.
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
15 years ago
Get a new host. They have not setup their web host properly. Sorry, I cannot assist further.
ekaleido
  • ekaleido
  • 59.6% (Neutral)
  • YAF Forumling Topic Starter
15 years ago
Jaben wrote:

Get a new host. They have not setup their web host properly. Sorry, I cannot assist further.



Can you possibly explain what the code is trying to do so I can provide an explanation, and possibly a fix, to my hosting provider? I'm fairly Windows-savvy, just not code-savvy. Thanks!
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
15 years ago
They are not supporting AJAX extensions.
devvvy
  • devvvy
  • 52.4% (Neutral)
  • YAF Forumling
14 years ago
Sorry may I ask exactly what you mean by "They are not supporting AJAX extensions."

I am running into same problem with latest YAF, again, 1and1 and my hosting provider.
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
14 years ago
devvvy wrote:

Sorry may I ask exactly what you mean by "They are not supporting AJAX extensions."

I am running into same problem with latest YAF, again, 1and1 and my hosting provider.


Different problem.
YAF Logo Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved
About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button