YAFLogo

Posted by: Rockhound21 - Thursday, 20 November 2008 04:59:26
Hello everyone, i need some serious help with installing YAF. im in a web design internship class at my high school, and i've been trying to install YAF for a little over a month. i keep following the instructions they give you, but no no avail. i was hoping someone could help me out. i already tried doing what this guy said http://forum.yetanotherforum.net/yaf_postst2438_Total-Newbie-Needs-Help-Installing-and-Setting-up.aspx but even that wont work. here's my situation: im on windows vista. i have SQL server 2008 installed, IIS 7 installed, .net framework 3.5 installed. my server is up and running locally i guess, i do have the inetpub/wwwroot folders on my C:drive i also created my own database called yafdatabase in the SQL Server Management Studio application i unzipped YAF-v1.9.1.8-FINAL-BIN to C:/inetpub/wwwroot/YAFFORUM i went into IIS and right clicked those files to make it an application Here's what i did: i went into my files, and they told me to rename default.config to web.config. then i opened up yafnet.config and deleted the value within connstr, and replaced it with Driver={SQL Server Native Client 10.0};Server=myServerAddress;Database=myDataBase;Uid=myUsername;Pwd=myPassword; like the instructions told me to do on yaf's info wiki. i copied the files from the /bin folder from my unzipped files over to the /binn (thats how its spelled) on my server i added C:\inetpub\wwwroot\YAFFORUM to yafnet.config and web.config under the yafnet parameter. then i tried running default.aspx in the install folder and no dice. could someone provide a detailed how-to? and can someone explain to me in where do i put ? what should the value in between root look like? thanks a bunch, guys!:)

Posted by: Mek - Thursday, 20 November 2008 09:24:11
If your website in ISS is pointing directly to c:\inetpub\wwwroot\YAFFORUM then no need to put the root entry into the config. Also make sure asp.net 2.0 is installed. Make sure the website in iis is running with asp.net once its installed (i've had odd ocasions when it wasnt even listed in the options). Also whatever error your getting would be nice.