YAFLogo

ibrahimk
  • ibrahimk
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
4 years ago
I am running YAF.NET 2.24.20 on a DNN 9.4.1 site, and I am getting the following error when I post or edit a post:

ModuleId:-1

ModuleDefId:-1

FriendlyName:

ModuleControlSource:

AbsoluteURL:/Default.aspx

DefaultDataProvider:DotNetNuke.Data.SqlDataProvider, DotNetNuke

ExceptionGUID:14409ee2-7389-4726-8842-28024f4d8808

AssemblyVersion:9.4.1

PortalId:0

UserId:1

TabId:32

RawUrl:/forums/g/posts/m/1/forum-rules

Referrer:

UserAgent:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.163 Safari/537.36

ExceptionHash:sVCFv9zw+N7tS9EU2rSoqp3EuDA=

Message:Couldn't load menu style 'Resources/1': System.ArgumentException: Illegal characters in path. at System.Security.Permissions.FileIOPermission.CheckIllegalCharacters(String[] str, Boolean onlyCheckExtras) at System.Security.Permissions.FileIOPermission.AddPathList(FileIOPermissionAccess access, AccessControlActions control, String[] pathListOrig, Boolean checkForDuplicates, Boolean needFullPath, Boolean copyPathList) at System.Security.Permissions.FileIOPermission..ctor(FileIOPermissi

StackTrace:

InnerMessage:Couldn't load menu style 'Resources/1': System.ArgumentException: Illegal characters in path. at System.Security.Permissions.FileIOPermission.CheckIllegalCharacters(String[] str, Boolean onlyCheckExtras) at System.Security.Permissions.FileIOPermission.AddPathList(FileIOPermissionAccess access, AccessControlActions control, String[] pathListOrig, Boolean checkForDuplicates, Boolean needFullPath, Boolean copyPathList) at System.Security.Permissions.FileIOPermission..ctor(FileIOPermissi

InnerStackTrace:

at DotNetNuke.Web.DDRMenu.MenuBase.Instantiate(String menuStyle)

at DotNetNuke.Web.DDRMenu.SkinObject.OnPreRender(EventArgs e)

Source:

FileName:

FileLineNumber:0

FileColumnNumber:0

Method:

Server Name: W26

Sponsor
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
4 years ago
This looks like an issue with your skin. Make sure all files exist for your skin.
ibrahimk
  • ibrahimk
  • 51.2% (Neutral)
  • YAF Forumling Topic Starter
4 years ago
Thanks for your reply. Can you please provide more information? I am using the Porto skin by Mandeeps.
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 4.0.0 rc 2
4 years ago

Thanks for your reply. Can you please provide more information? I am using the Porto skin by Mandeeps.

Originally Posted by: ibrahimk 

Sorry but with a paid product i cant help you. I dont have any option to test this. The only think i found is this...

https://stackoverflow.com/questions/26585782/dotnetnuke-ddrmenu-couldnt-load-menu-style-menuprofile-illegal-characters 

otherwise you would need to contact the owner of that skin